I had an error in this command: launch MY_FIRST_MG5_RUN

Asked by Raghad Badawi

INFO: Combining runs
sum of cpu time of last step: 22 seconds
INFO: finish refine
refine 10000 --treshold=0.9
No need for second refine due to stability of cross-section
INFO: Combining Events
combination of events done in 5.136702060699463 s
  === Results Summary for run: run_01 tag: tag_1 ===

     Cross-section : 505.8 +- 0.7269 pb
     Nb of events : 10000

Failed to access python version of LHAPDF: If the python interface to LHAPDF is available on your system, try adding its location to the PYTHONPATH environment variable and theLHAPDF library location to LD_LIBRARY_PATH (linux) or DYLD_LIBRARY_PATH (mac os x).The required LD_LIBRARY_PATH is /home/raghad/Downloads/MG5_aMC_v3_5_3/HEPTools/lhapdf6_py3//lib
INFO: can not run systematics since can not link python to lhapdf
INFO: Storing parton level results
INFO: End Parton
reweight -from_cards
INFO: Extracting the banner ...
INFO: process: p p > t t~
INFO: options:
INFO: Running Reweighting
change mode NLO # Define type of Reweighting. For LO sample this command
WARNING: Missing information for NLO type of reweighting. Keeping the mode to LO.
INFO: detected model: sm. Loading...
INFO: generating the square matrix element for reweighting
INFO: generate p p > t t~ ;
INFO: Done 1.626
Command "generate_events run_01" interrupted with error:
ModuleNotFoundError : No module named 'rw_me.SubProcesses.P1_gg_ttx2py'
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in '/home/raghad/Downloads/MG5_aMC_v3_5_3/MY_FIRST_MG5_RUN/run_01_tag_1_debug.log'.
Please attach this file to your report.
INFO: storing files of previous run
gzipping output file: unweighted_events.lhe
INFO: Done
INFO: Original cross-section: 505.787 +- 0.7268924 pb
INFO: Computed cross-section:
Command "f2py" not recognized, please try again

Question information

English Edit question
MadGraph5_aMC@NLO Edit question
No assignee Edit question
Solved by:
Olivier Mattelaer
Last query:
Last reply:
Revision history for this message
Best Olivier Mattelaer (olivier-mattelaer) said :


The issue is likely related to a missing f2py executable or a f2py executable not compatible with your python version.
But that module/requirement of f2py is quite advance and therefore surprising for a "MY_FIRST_MG5_RUN"
So do you really want to use such feature?

Note that in general the best way to install f2py is to do
pip3 install numpy --user

and then check where pip3 did install the f2py executable and either put that path in the madgraph configuration file
or add it to your environment obviously



Revision history for this message
Raghad Badawi (r-b-99) said :
Revision history for this message
Raghad Badawi (r-b-99) said :
Revision history for this message
Raghad Badawi (r-b-99) said :

I don't know if this is still relevant, because I ran into other errors trying to solve it.
I formatted the laptop and reinstalled madgraph again, solved a couple of my problems, but not the python interface to LHAPDF.