Installation error

Asked by Max Fusté Costa


I have both python 3.9.13 and 2.7.18. I'm trying to install maddm, but I get the following message:

You are installing 'maddm', please cite ref(s): arXiv:1804.00444.
--2023-03-10 15:00:28--
Resolving (
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 600218 (586K) [application/x-gzip]
Saving to: ‘maddm.tgz’

maddm.tgz 100%[===================>] 586.15K 3.09MB/s in 0.2s

2023-03-10 15:00:28 (3.09 MB/s) - ‘maddm.tgz’ saved [600218/600218]

compile maddm. This might take a while.
no compilation needed for plugin. Loading plugin information
No module named 'maddm_interface'
Plugin not python3 compatible! It will run with python2
Plugin maddm correctly interfaced. Latest official validition for MG5aMC version .
To use this module, you need to quit MG5aMC and run the executable bin/
Installation succeeded

When I then try to run maddm I get the message:

ModuleNotFoundError: No module named 'maddm_interface'

I've seen that maddm only works with python 2. However, if I try to make the installation or run maddm with python 2 I get the following message:

MadGraph5_aMC@NLO works only with python 3.7 (and later).
  You are currently using Python2.7. Please use a more recent version of Python.

What can I do about this?


Question information

English Edit question
MadGraph5_aMC@NLO Edit question
No assignee Edit question
Solved by:
Max Fusté Costa
Last query:
Last reply:
Revision history for this message
amir subba (amir4hep) said :

What version of MadGraph5 are you using? I suggest you to get the specific version of MAdGraph5 compatible to python2. And then built required packages inside madgraph.

Revision history for this message
Max Fusté Costa (max6399) said :

I'm using version 3.4. I have tried with previous versions of MAdGraph5 (namely 2.8 and 2.9) and I get an error when trying to run it that says "ImportError: No module named numpy.core.fromnumeric". I have checked if numpy was correctly installed (it was), and it keeps giving the same error. What can it be?


Revision history for this message
Max Fusté Costa (max6399) said :


I have solved this numpy issue (it was not properly updated). MadDM is not compatible with MadGraph 2.8, so I will keep checking versions until I hit the spot.

Thank you kindly!!