standalone matrix element

Asked by Yingjie Wei

Hi Madgraph experts:

    I am trying to generate an ME standalone python library.

The setup: (1.1) Madgraph 2.9.3
                      (1.2)python 2.7.16

    I use the following command to generate this library:

[$]python ./bin/mg5_aMC

and in MG5_aMC:

 set max_npoint_for_channel 4
    import model /cvmfs/
   #or you could find the model here:

    define p = g u c d s b u~ c~ d~ s~ b~
    define j = g u c d s b u~ c~ d~ s~ b~
    define l+ = e+ mu+
    define l- = e- mu-

NORMALLY: if I generate the events, I will use:
    generate g g > l+ l- l+ l- / g QCD=2 QED=4 NP=2 NP^2==2 [noborn=QCD]
    output -f

There is no problem with the above commands.

BUT for generating the standalone python package:
   The [noborn=QCD] probably is not suitable as it doesn't allow me to use: output standalone gg4l_ctpSM_cpGSM_standalone)
   Or [virt=QCD] is still not correct as I want to generate loop-level diagrams only (no born diagrams).

So I change the commands to:
   generate g g > l+ l- l+ l- / g QCD=2 QED=4 NP=2 NP^2==2 [sqrvirt=QCD] #(I am not sure whether this is correct or not)
   output standalone gg4l_ctpSM_cpGSM_standalone_python_2.7.16 --prefix=int

after I run: launch -f

I got:

*****************************start of error********************************
MG5_aMC>launch -f
Initializing process gg > epemmupmum.
Error detected in "launch -f"
write debug file MG5_debug
If you need help with this issue please contact us on
str : A compilation Error occurs when trying to compile /home/weiy/Desktop/Pre_ox13/twoD_fit/EFT/ME/MG5_aMC_v2_9_3/gg4l_ctpSM_cpGSM_standalone_python_2.7.16/SubProcesses/P0_gg_epemmupmum_no_g.
 The compilation fails with the following output message:
     gfortran -w -fPIC -ffixed-line-length-132 -O3 -c polynomial.f -o polynomial.o
     gfortran -w -fPIC -ffixed-line-length-132 -c check_sa.f -o check_sa.o
     gfortran -w -fPIC -ffixed-line-length-132 -c MadLoopParamReader.f -o MadLoopParamReader.o
     gfortran -w -fPIC -ffixed-line-length-132 -c MadLoopCommons.f -o MadLoopCommons.o
     gfortran -w -fPIC -ffixed-line-length-132 -c loop_matrix.f -o loop_matrix.o
     gfortran -w -fPIC -ffixed-line-length-132 -c improve_ps.f -o improve_ps.o
     gfortran -w -fPIC -ffixed-line-length-132 -c CT_interface.f -o CT_interface.o
     gfortran -w -fPIC -ffixed-line-length-132 -c loop_num.f -o loop_num.o
     gfortran -w -fPIC -ffixed-line-length-132 -c helas_calls_ampb_1.f -o helas_calls_ampb_1.o
     gfortran -w -fPIC -ffixed-line-length-132 -c mp_compute_loop_coefs.f -o mp_compute_loop_coefs.o
     gfortran -w -fPIC -ffixed-line-length-132 -c mp_helas_calls_ampb_1.f -o mp_helas_calls_ampb_1.o
     gfortran -w -fPIC -ffixed-line-length-132 -c coef_construction_1.f -o coef_construction_1.o
     gfortran -w -fPIC -ffixed-line-length-132 -c loop_CT_calls_1.f -o loop_CT_calls_1.o
     gfortran -w -fPIC -ffixed-line-length-132 -c mp_coef_construction_1.f -o mp_coef_construction_1.o
     gfortran -w -fPIC -ffixed-line-length-132 -c TIR_interface.f -o TIR_interface.o
     gfortran -w -fPIC -ffixed-line-length-132 -c compute_color_flows.f -o compute_color_flows.o
     make: *** No rule to make target `../../lib/libiregi.a', needed by `check'. Stop.

 Please try to fix this compilations issue and retry.
 Help might be found at
 If you think that this is a bug, you can report this at

*********************************end of error*********************************

  I am not sure whether the: generate g g > l+ l- l+ l- / g QCD=2 QED=4 NP=2 NP^2==2 [sqrvirt=QCD]
is correct or not to generate the standalone library.

Could you please help me with this? Really appreciated!


Question information

English Edit question
MadGraph5_aMC@NLO Edit question
No assignee Edit question
Solved by:
Yingjie Wei
Last query:
Last reply:
Revision history for this message
Yingjie Wei (yingjiewei) said :


    I think I solve the error:

   cd /home/weiy/Desktop/Pre_ox13/twoD_fit/EFT/ME/MG5_aMC_v2_9_3/gg4l_ctpSM_cpGSM_standalone_python_2.7.16/SubProcesses/Source/IREGI/src
   and run: make

   Thanks anyway!

But could I just confirm that:

   [sqrvirt=QCD] is: noborn= QCD && virt=QCD ?


Revision history for this message
Olivier Mattelaer (olivier-mattelaer) said :


Good job, yes indeed "sqvirt=" is the equivalent of "noborn=" for standalone code.



Revision history for this message
Yingjie Wei (yingjiewei) said :

Thanks a lot, Olivier! This is really helpful!