NLO MODE

Asked by Sarah

Hello

I downloaded Madgraph v 3.2.0 and I generated processes. Now I want to generate processes that have loop diagrams and I think they can be generated by aMC@NLO.
I followed the tutorial aMC@NLO until it was done.
How can I download the mode aMC@NLO in Madgraph ? is it in Madgraph ?

sorry if this is stupid question

best regards
Sarah

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Sarah
Solved:
Last query:
Last reply:
Revision history for this message
Olivier Mattelaer (olivier-mattelaer) said :
#1

Do you mean loop-induced process?
then reference paper is 1507.00020 <https://arxiv.org/abs/1507.00020> [hep-ph]

Where you will find all the instruction for such type of process.

If this is not what you are asking for then please give me more details.

Cheers,

Olivier

> On 19 Oct 2021, at 14:50, Sarah <email address hidden> wrote:
>
> New question #699159 on MadGraph5_aMC@NLO:
> https://answers.launchpad.net/mg5amcnlo/+question/699159
>
> Hello
>
> I downloaded Madgraph v 3.2.0 and I generated processes. Now I want to generate processes that have loop diagrams and I think they can be generated by aMC@NLO.
> I followed the tutorial aMC@NLO until it was done.
> How can I download the mode aMC@NLO in Madgraph ? is it in Madgraph ?
>
>
> sorry if this is stupid question
>
> best regards
> Sarah
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Revision history for this message
Sarah (sarahwarad) said :
#2

Thank you Olivier for your reply.

I want to generate this process g g > h z, z > l+ l-
this process can occur only in quantum level. g g go to cp odd Higgs Boson (A) and the A goes to z and h (the SM Higgs like) then z goes to l+ l-. Z here is off shell .

I tried to generate it in 2HDM _NLO model, but it says there is no amplitude.
can I generate g g > h l+ l- in sm loop model?

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) said :
#3

The comma syntax is not compatible with loop induced processes.
So here you can use the syntax
generate g g > h l+ l- [QCD]

You can use the model that you want but the real question is if you do a computation in the SM how much similar it is compare to 2HDM model. In other word, why is it not working within 2HDM?

Revision history for this message
Sarah (sarahwarad) said :
#4

Good morning Olivier
these are my attempts in sm 2hdm and 2hdm_nlo

import model loop_sm
INFO: Restrict model loop_sm with file models/loop_sm/restrict_default.dat .
INFO: Run "set stdout_level DEBUG" before import for more information.
INFO: Change particles name to pass to MG5 convention
Kept definitions of multiparticles p / j / l+ / l- / vl / vl~ / q / q~ unchanged
Defined multiparticle all = g gh gh~ d u s c d~ u~ s~ c~ a ve vm vt e- mu- ve~ vm~ vt~ e+ mu+ b t b~ t~ z w+ h w- ta- ta+
INFO: Checking for minimal orders which gives processes.
INFO: Please specify coupling orders to bypass this step.
INFO: Trying coupling order WEIGHTED<=6: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=7: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=8: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=9: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=10: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=11: WEIGTHED IS QCD+2*QED
Error detected in "generate g g > e+ e- h [QCD]"
write debug file MG5_debug
If you need help with this issue please contact us on https://answers.launchpad.net/mg5amcnlo
str :
 Automatic process-order determination lead to negative constraints:
 QED: 9, QCD: -6
 Please specify the coupling orders from the command line.
MG5_aMC>import model 2HDM
INFO: Change particles name to pass to MG5 convention
Kept definitions of multiparticles p / j / l+ / l- / vl / vl~ / q / q~ unchanged
Removed obsolete multiparticles all
Defined multiparticle all = g u c d s u~ c~ d~ s~ a ve vm vt e- mu- ta- ve~ vm~ vt~ e+ mu+ ta+ t b t~ b~ z w+ h+ h1 h2 h3 w- h-
MG5_aMC>generate g g > h2 e+ e- [QCD]
The current model 2HDM does not allow to generate loop corrections of type ['QCD'].
Command "generate g g > h2 e+ e- [QCD]" interrupted with error:
InvalidCmd : The model 2HDM cannot handle loop processes
MG5_aMC>import model 2HDM_NLO
INFO: Change particles name to pass to MG5 convention
Kept definitions of multiparticles p / j / l+ / l- / vl / vl~ / q / q~ unchanged
Defined multiparticle all = g ghg ghg~ u c d s u~ c~ d~ s~ a gha gha~ ve vm vt e- mu- ta- ve~ vm~ vt~ e+ mu+ ta+ t b t~ b~ z w+ ghz ghwp ghwm h+ h1 h2 h3 w- ghz~ ghwp~ ghwm~ h-
MG5_aMC>generate g g > h2 e+ e- [QCD]
INFO: Checking for minimal orders which gives processes.
INFO: Please specify coupling orders to bypass this step.
INFO: Trying coupling order WEIGHTED<=6: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=7: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=8: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=9: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=10: WEIGTHED IS QCD+2*QED
INFO: Trying coupling order WEIGHTED<=11: WEIGTHED IS QCD+2*QED
Error detected in "generate g g > h2 e+ e- [QCD]"
write debug file MG5_debug
If you need help with this issue please contact us on https://answers.launchpad.net/mg5amcnlo
str :
 Automatic process-order determination lead to negative constraints:
 QED: 9, QCD: -6
 Please specify the coupling orders from the command line.
MG5_aMC>

since this process occurs only in quantum levels can I use the tag noborn CQD?

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) said :
#5

I typically prefer to not use [noborn=QCD] and prefer to use [QCD] since the second one check that you do not have any tree level diagram. but if you know that you do not have those you can give the information and then MG5aMC will not check it.

Here the issue is that it fails to find the appropriate order for a_S and a_EW for your process. So you have to specify one rather than using our default for it (which fails to find any relevant default)
generate g g > h2 e+ e- QED<=3 [QCD].

Cheers,

Olivier

PS: I do not know the term "quantum levels", so I can not comment on that statement.

Revision history for this message
Sarah (sarahwarad) said :
#6

Thank you Olivier for your reply

Quantum level means loop diagrams

I did what you wrote and that what I got

MG5_aMC>import model 2HDM_NLO
INFO: Change particles name to pass to MG5 convention
Kept definitions of multiparticles p / j / l+ / l- / vl / vl~ unchanged
Defined multiparticle all = g ghg ghg~ u c d s u~ c~ d~ s~ a gha gha~ ve vm vt e- mu- ta- ve~ vm~ vt~ e+ mu+ ta+ t b t~ b~ z w+ ghz ghwp ghwm h+ h1 h2 h3 w- ghz~ ghwp~ ghwm~ h-
MG5_aMC>generate g g > h2 e+ e- QED<=3 [QCD]
Command "generate g g > h2 e+ e- QED<=3 [QCD]" interrupted with error:
Exception : Potentially ambigious syntax detected. Note that the syntax of paper 1804.10017 (used in 3.0.x) is not used anymore (since version 3.1.0).
 If you want to follow the syntax of that paper, you can just replace "QED" by "aEW" and "QCD" by "aS".
 More information here: http://amcatnlo.cern.ch/co.htm
 If you know the current meaning of the syntax you can bypass this crash by running (once per machine) this command:
  set acknowledged_v3.1_syntax True --global
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in 'MG5_debug'.
Please attach this file to your report.
MG5_aMC>generate g g > h2 e+ e- aEW<=3 [aS]
------------------------------------------------------------------------
This computation involve not SM-QCD corrections at NLO.
Please also cite ref. 'arXiv:1804.10017' when using results from this code.
------------------------------------------------------------------------

The current model 2HDM_NLO does not allow to generate loop corrections of type ['aS'].
Command "generate g g > h2 e+ e- aEW<=3 [aS]" interrupted with error:
InvalidCmd : The model 2HDM_NLO cannot handle loop processes
MG5_aMC>

I want to reproduce the data for second process in the paper https://arxiv.org/pdf/2002.07038.pdf

I did the first one q q > h l+ l- and it was easy because it it tree level diagrams.

I am really sorry if I bather you with my questions, I really appreciate you

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) said :
#7

just enter (need to be done only once)
set acknowledged_v3.1_syntax True --global

and then you can use the syntax:
generate g g > h2 e+ e- QED<=3 [QCD]

the syntax that might not need to acknoledged the syntax is likely
 generate g g > h2 e+ e- aEW<=3 [QCD]
but ok

Olivier

Revision history for this message
Sarah (sarahwarad) said :
#8

Unfortunately, I couldn't

Revision history for this message
Sarah (sarahwarad) said :
#9

Hello Olivier

I could run the process in 2HDMtII_NLO
generate g g > h3 > h2 e+ e- [ noborn=QED}
I got unwanted diagrams with photon, ( h3 > a h2 then a goes to e+ e-). how can I get diagrams without photon?

I tried to specify the process by set [QED<=2] but I couldn't generate the process

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) said :
#10

So this is not mediated via a top quark loop?
you can test the following syntax
generate g g > h3 Z > h2 e+ e- [ noborn=QED]
or
generate g g > h3 > h2 e+ e- / a [ noborn=QED]

but be sure that you impose a stronf invariant mass cut (close to the z mass) since removing photo diagram breaks gauge and lorentz invariance of the computation in general (i.e. you will have unphysical distribution in the tail)

Cheers,

Olivier

Revision history for this message
Sarah (sarahwarad) said :
#11

Thank you Olivier
I got the diagrams I want.

the diagrams I got are triangle diagrams, how can I got the box diagram ?
I think I have to tun off the ggh3 effective vertex, I wrote
MG5_aMC>generate g g > h3 > h2 e+ e- / a [ noborn=QCD] ggh3==0
Command "generate g g > h3 > h2 e+ e- / a [ noborn=QCD] ggh3==0" interrupted with error:
InvalidCmd : model order ggh3 not valid for this model (valid one are: QCD, QED, EW, EW^2, aEW, aS). Please correct
MG5_aMC>

Can you help me with that, please?
I want to have the triangle and box diagrams

best regards
Sarah

Revision history for this message
Sarah (sarahwarad) said :
#12

I opened vertices.py in the Model I am using and there are more vertices, I copied the first three one:

V_1 = Vertex(name = 'V_1',
             particles = [ P.G0, P.G0, P.G0, P.G0 ],
             color = [ '1' ],
             lorentz = [ L.SSSS1 ],
             couplings = {(0,0):C.GC_29})

V_2 = Vertex(name = 'V_2',
             particles = [ P.G0, P.G0, P.G__minus__, P.G__plus__ ],
             color = [ '1' ],
             lorentz = [ L.SSSS1 ],
             couplings = {(0,0):C.GC_27})

V_3 = Vertex(name = 'V_3',
             particles = [ P.G__minus__, P.G__minus__, P.G__plus__, P.G__plus__ ],
             color = [ '1' ],
             lorentz = [ L.SSSS1 ],
             couplings = {(0,0):C.GC_28})

Also I opend coupling orders.py

from object_library import all_orders, CouplingOrder

QCD = CouplingOrder(name = 'QCD',
                    expansion_order = 99,
                    hierarchy = 1,
                    perturbative_expansion = 1)

QED = CouplingOrder(name = 'QED',
                    expansion_order = 99,
                    hierarchy = 2)

What do I have to change to get the both diagrams?

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) said :
#13

To turn off some coupling you have to use the following method:
https://answers.launchpad.net/mg5amcnlo/+faq/2312

The reason why you do not have box is likely because you ask for h3 to be in s-channel, i guess this is not possible with a box.
So if you want box, you likely need
generate g g > h2 e+ e- / a [ noborn=QCD]

Cheers,

Olivier

Revision history for this message
Sarah (sarahwarad) said :
#14

thank you Olivier
my problem is solved