update error: can't find directory

Asked by chang tien ho

I am trying to install Madgraph5 to my lxplus account,
I followed the instructions from https://twiki.cern.ch/twiki/bin/view/Main/MadgraphOnLxPlus
which tells me to type the command "/afs/cern.ch/user/z/zflowers/public/InstallMadgraph/install_madgraph.sh" in order to install
the installation was successful, which in includes the all the tools such as Madanalysis and Delphes.
However the version was 2.6.7 and using the install update command I tried to update the program.
the update was running smoothly until it tries to install this:

--2021-09-11 06:32:42-- http://madgraph.phys.ucl.ac.be/binary/binary_file288.tgz
Resolving madgraph.phys.ucl.ac.be (madgraph.phys.ucl.ac.be)... 130.104.133.249
Connecting to madgraph.phys.ucl.ac.be (madgraph.phys.ucl.ac.be)|130.104.133.249|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1690 (1.7K) [application/x-gzip]
Saving to: 'extra_file288.tgz'

100%[===========================================================================>] 1,690 --.-K/s in 0.005s

2021-09-11 06:32:42 (322 KB/s) - 'extra_file288.tgz' saved [1690/1690]

move Template/SubProcesses/addmothers.f to madgraph/iolibs/template_files/addmothers.f

where it fails to find a path

Command "install update " interrupted in sub-command:
"install update" with error:
OSError : [Errno 2] No such file or directory: '/afs/cern.ch/user/t/tichang/Madgraph/MG5_aMC_v2_6_7/Template/SubProcesses/addmothers.f'
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in 'MG5_debug'.
Please attach this file to your report.

I've deleted the Madgraph file to install and update it again and ran into the same problem.
should I manually create the path, and would this create any problems? Or is there another way to install a newer version where this error might be patched?

Thank you,
tien-ho Chang

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
Last query:
Last reply:
Revision history for this message
Best Olivier Mattelaer (olivier-mattelaer) said :
#1

Hi,

2.6.7 is out of support, so this make sense that many of the "install" command does not work on that version anymore.
The script that you mention is not done by us so I can not comment on it
Please install 2.9.5 (our long term stable version) or 3.2.0 (our latest feature version).

Cheers,

Olivier

PS: Installation of MG5aMc is very simple, since you basically only need to untar the tarball.

Revision history for this message
chang tien ho (tichang) said :
#2

Thanks Olivier Mattelaer, that solved my question.