Error detected in "generate_events"

Asked by Craig Shewry

Hi all,

I've just got MadGraph up and running but when running through the tutorial I keep getting a compilation error at the generate_events stage. I've tried changing some of the config settings but nothing seems to be helping.

Here's the debug log:

internal.MadGraph5Error: A compilation Error occurs when trying to compile /home/craig/Downloads/MG5_aMC_v3_2_0/HELLO/SubProcesses/P1_gg_ttx.
The compilation fails with the following output message:
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c driver.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c myamp.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c genps.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c unwgt.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c setcuts.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c get_color.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c cuts.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c cluster.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c reweight.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c initcluster.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c addmothers.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c setscales.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c idenparts.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c dummy_fct.f -I../../Source/
    gfortran -w -fPIC -O -ffixed-line-length-132 -w -c auto_dsig1.f -I../../Source/
    auto_dsig1.f:52: Error: Can't open included file '../../Source/PdF/'
    make: *** [makefile:71: auto_dsig1.o] Error 1
    make: *** Waiting for unfinished jobs....

Please try to fix this compilations issue and retry.
Help might be found at
If you think that this is a bug, you can report this at
                              Run Options
               stdout_level : None

                         MadEvent Options
     automatic_html_opening : False (user set)
        notification_center : True
                   run_mode : 2
              cluster_queue : None
               cluster_time : None
               cluster_size : 100
             cluster_memory : None
                    nb_core : 8 (user set)
          cluster_temp_path : None

                      Configuration Options
               pythia8_path : None (user set)
                  hwpp_path : None (user set)
                thepeg_path : None (user set)
                 hepmc_path : None (user set)
           madanalysis_path : None (user set)
          madanalysis5_path : None (user set)
            pythia-pgs_path : None (user set)
                    td_path : None (user set)
               delphes_path : None (user set)
        exrootanalysis_path : None (user set)
               syscalc_path : None (user set)
                     lhapdf : lhapdf-config
                 lhapdf_py2 : None
                 lhapdf_py3 : None
                    timeout : 60
              f2py_compiler : gfortran (user set)
          f2py_compiler_py2 : gfortran (user set)
          f2py_compiler_py3 : gfortran (user set)
                web_browser : brave (user set)
                 eps_viewer : okular (user set)
                text_editor : nvim (user set)
           fortran_compiler : None
               cpp_compiler : g++ (user set)
                auto_update : 7 (user set)
               cluster_type : condor
      cluster_status_update : (600, 30)
           cluster_nb_retry : 1
         cluster_local_path : None
         cluster_retry_wait : 300

Thanks in advance!

Question information

English Edit question
MadGraph5_aMC@NLO Edit question
No assignee Edit question
Solved by:
Olivier Mattelaer
Last query:
Last reply:
Revision history for this message
Olivier Mattelaer (olivier-mattelaer) said :

Ah, this I do not reproduce on my mac because mac is case insensitive for the path.
I guess that you are on linux where this is not the case.

here is a simple patch:

=== modified file 'madgraph/iolibs/template_files/'
--- madgraph/iolibs/template_files/ 2021-04-23 10:45:26 +0000
+++ madgraph/iolibs/template_files/ 2021-08-24 13:11:49 +0000
@@ -46,7 +46,7 @@
- include '../../Source/PdF/'
+ include '../../Source/PDF/'
       double precision ee_comp_prod
       integer i_ee

Will fix the official tarball very soon

Revision history for this message
Best Olivier Mattelaer (olivier-mattelaer) said :

The tarball has been updated with the fix.

Thanks a lot,


Revision history for this message
Craig Shewry (craigmadethis) said :

Thanks Olivier Mattelaer, that solved my question.