Pythia version mismatch

Asked by Haoyi Jia

Hi! I have Pythia8 intalled in Madgraph5. While merging results from the split PY8 runs, it got error msg:
"Histogram with run_id '0' was not found in the specified XML source."
I see there are same problems that has been solved on this forum. I've set my run_mode to 0 or 2, both not work. Also, I've tried set PYTHIA8DATA to MG5_dir/HEPTools/pythia8/share/Pythia8/xmldoc. But the problem stills exist.

Question information

English Edit question
MadGraph5_aMC@NLO Edit question
No assignee Edit question
Solved by:
Olivier Mattelaer
Last query:
Last reply:
Revision history for this message
Best Olivier Mattelaer (olivier-mattelaer) said :

As far as I know, everyone with that issue fixed it by setting the environment variable.
Are you sure that you use the correct syntax for setting such a type of variable?
Otherwise, I would advise asking pythia8 author who should have a better understanding than us for such issue.



Revision history for this message
Haoyi Jia (kn-jia625) said (last edit ):

Thank you! Later I realized that cmsenv overwrite that environment variable.