The inclusion of gg > hh sub-process in the general pp > hh process

Asked by Harshal Kulkarni on 2021-05-25

Hi all,
          I am working with the pp > hh process in the SM on the webserver of MG. I saw that the Feynman diagram of this process only involves the bb~ > hh sub-process and not the gg > hh sub-process which occurs with a ggh coupling if I am not mistaken. It seems that MG5 does not have these interaction vertices included by default. Is there a way to ensure that the interaction vertex ggh will be present and hence we will get a gg > hh sub-process as well? If it is not included by default, then how can I turn it on?

Thanks,
Harshal

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
Last query:
Last reply:
Revision history for this message
Best Olivier Mattelaer (olivier-mattelaer) said :
#1

Hi,

Indeed ggh is not in the standard model since such interactions does not exits in the standard model.
So you should use the loop-induced mode:
generate g g > h h [QCD]

In theory you can use another model which shrink the loop in term of effective operator.
You have for example the heft model for that.
Such type of model do have a ggh lorentz structure but this has a price since you do an expansion over shat/mt.
And therefore using such model for di-higgs is not accurate (since 2 times the mass of the higgs is heavier than the top mass).

Now you can check the litterature on all the trick that does exists for such process especially if you do want NLO accuracy.

Cheers,

Olivier

Revision history for this message
Harshal Kulkarni (hck18ms056) said :
#2

Thanks Olivier Mattelaer, that solved my question.

Revision history for this message
Harshal Kulkarni (hck18ms056) said :
#3

Hi, I used "generate gg > hh" in SM, but as expected, it is only present in loop_sm, hence I imported loop_sm and then used generate gg > hh [QCD] and got 1 process with 16 diagrams. However when I tried storing the output in a local directory, this is the error I got:

Command "output gg_hh" interrupted with error:
FileNotFoundError : [Errno 2] No such file or directory: '/mnt/c/Users/Harshal.Kulkarni/MG/MG5_aMC_v2_9_3/madgraph/iolibs/template_files/loop_optimized/check_sa_loop_induced.inc'
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in 'MG5_debug'.
Please attach this file to your report.

What does it mean, and what can I do to avoid this? Should I attach the debug file here?

Revision history for this message
Olivier Mattelaer (olivier-mattelaer) said :
#4

Not sure what you did but looks like you remove some template file within the MG5aMC code and therefore the generation of loop induced process is not working anymore. My only advice is to re-install MG5aMC.

Cheers,

Olivier