Issue while using pt_min_pdg cut in Madgraph

Asked by Mohit sharma on 2021-03-11

Hi Madgraph Experts,
I am generating the following process :

define lx = e+ e- mu+ mu-
define tax = ta+ ta-
define lax = lx tax
define vx = ve vm vt vm~ vm~ vt~
generate p p > t t~ j j, (t > b lax vx), (t~ > b~ lax vx) @1

I want to apply pt_min_pdg cut {6: 100.0} for top quark but I am aware that this cut would work only for final state particles. So I am making use of Madspin as suggested here by @olivier-mattelaer -> https://answers.launchpad.net/mg5amcnlo/+question/666825. But while using madspin I am unable to apply any cuts (e.g ptl, mmll etc) on the decay particles since the run card only allow cuts on propagator (top & jets). Is there any other way to do it? Any help would be much appreciated.
Thanks,
Mohit

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2021-03-11
Last reply:
2021-03-11

The only other option is to hard code a new cut inside the fortran code.

The big issue here is to check carefuully if the phase-space integrator will still behave correctly.
Adding a cut is technically simple but the issue is if the phase-space integrator will succeed to cope with the cuts or will converge trough an unphysical value. If you choose that method you should assume that the result is wrong but if you succeed to convince yourself of the opposite. You need in particular check all the log file linked in HTML/run_XX/results.html and carefully check all those logs (in particular if any of those returns a zero cross-section you need to understand if this makes sense or not)

to hardcode a cuts, you can edit the file SubProcesses/dummy_fct.f

Cheers,

Olivier

Can you help with this problem?

Provide an answer of your own, or ask Mohit sharma for more information if necessary.

To post a message you must log in.