How to apply cuts to final state leptons (after 2 decays)?

Asked by Henry on 2021-03-03

I am not doing a very good job of applying cuts to my final state leptons.
The process is;
``` generate p p > t t~, (t > b w+, (w+ > l+ vl)), (t~ > b~ w-, (w- > j j)) ```

And I would like the leptons in the final state (that decay from the w+) to have rapidity less than 2.4.

My run card contains;
```
 #*********************************************************************
 # Apply pt/E/eta/dr/mij/kt_durham cuts on decay products or not
 # (note that etmiss/ptll/ptheavy/ht/sorted cuts always apply)
 #*********************************************************************
   True = cut_decays ! Cut decay products
```
and also
```
#*********************************************************************
# Maximum and minimum absolute rapidity (for max, -1 means no cut) *
#*********************************************************************
 5.0 = etaj ! max rap for the jets
 -1.0 = etab ! max rap for the b
 2.4 = etal ! max rap for the charged leptons
 0.0 = etabmin ! min rap for the b
 0.0 = etalmin ! main rap for the charged leptons
 {11: 2.4| 13: 2.4} = eta_min_pdg ! rap cut for other particles (use pdg code). Applied on particle and anti-particle
 {} = eta_max_pdg ! rap cut for other particles (syntax e.g. {6: 2.5, 23: 5})
```
But for some reason the lepton that decays from the W is still varying in rapidity a lot. Is there something else I need to do to make the cut apply?

Many thanks,
Henry

Edit; Just in-case I have failed to include some key info I have uploaded a short run; https://ufile.io/cx8hkcvy
This was created with the latest (non beta) version of MG downloaded and installed today.

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
2021-03-03
Last query:
2021-03-03
Last reply:
2021-03-03

Just setting
2.4 = etal
and cut_decays=True
do the trick. I have run the code right now and made the plot with MadAnalysis5 and the cut is done correctly.

If you use the line
{11: 2.4, 13: 2.4} = eta_min_pdg
this impose a minimum cut and not a maximum cut.
Additionally setting that line for "11" and "13" has the side effect that the line "etal" is ignored
you could have use
{11: 2.4, 13: 2.4} = eta_min_pdg

Cheers,

Olivier

Henry (disreputabledog) said : #2

Thanks Olivier Mattelaer, that solved my question.