model_v4 not running

Asked by Sihyun Jeon on 2020-12-14

Dear MG team,

I am facing a trouble when using model_v4, generating events (with MGv265).
It works fine up to the part where I modify the runcards but it eventually fails when it tries to generate the events with it.
Other model_v4 works fine so would it be problem from the model card itself?

https://cms-project-generators.web.cern.ch/cms-project-generators/SSMZp/ssmzp_nonuniversal_v4.zip
https://cms-project-generators.web.cern.ch/cms-project-generators/SSMZp/ssmzp_nonuniversal_no_light_v4.zip

These are the two model files I tested and the one above is failing event generation while other is totally fine.

Regards,
Sihyun.

generate_events run_01
Traceback (most recent call last):
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/extended_cmd.py", line 1514, in onecmd
    return self.onecmd_orig(line, **opt)
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/extended_cmd.py", line 1463, in onecmd_orig
    return func(arg, **opt)
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/madevent_interface.py", line 2469, in do_generate_events
    self.run_generate_events(switch_mode, args)
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/common_run_interface.py", line 6869, in new_fct
    original_fct(obj, *args, **opts)
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/madevent_interface.py", line 2508, in run_generate_events
    postcmd=False)
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/extended_cmd.py", line 1543, in exec_cmd
    stop = Cmd.onecmd_orig(current_interface, line, **opt)
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/extended_cmd.py", line 1463, in onecmd_orig
    return func(arg, **opt)
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/madevent_interface.py", line 3277, in do_survey
    self.configure_directory()
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/madevent_interface.py", line 5607, in configure_directory
    self.compile(arg=[name], cwd=os.path.join(self.me_dir, 'Source'))
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/interface/extended_cmd.py", line 1607, in compile
    return misc.compile(nb_core=self.options['nb_core'], *args, **opts)
  File "/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/madgraph/various/misc.py", line 527, in compile
    raise MadGraph5Error, error_text
MadGraph5Error: A compilation Error occurs when trying to compile /data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/PROC_ssmzp_nonuniversal_v4_4/Source.
The compilation fails with the following output message:
    /cvmfs/cms.cern.ch/slc6_amd64_gcc630/external/gcc/6.3.0/bin/gfortran -O -w -fbounds-check -fPIC -ffixed-line-length-132 -c -o combine_events.o combine_events.f
    cd MODEL; make
    make[1]: warning: jobserver unavailable: using -j1. Add '+' to parent make rule.
    make[1]: Entering directory '/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/PROC_ssmzp_nonuniversal_v4_4/Source/MODEL'
    make[1]: Nothing to be done for 'all'.
    make[1]: Leaving directory '/data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/PROC_ssmzp_nonuniversal_v4_4/Source/MODEL'
    /cvmfs/cms.cern.ch/slc6_amd64_gcc630/external/gcc/6.3.0/bin/gfortran -o ../bin/internal/combine_events combine_events.o rw_events.o ranmar.o kin_functions.o open_file.o rw_routines.o alfas_functions.o setrun.o -L../lib/ -lmodel -lpdf -lstdc++ -lbias
    setrun.o: In function `setrun_':
    setrun.f:(.text+0x929): undefined reference to `setpara_'
    collect2: error: ld returned 1 exit status
    makefile:62: recipe for target '../bin/internal/combine_events' failed
    make: *** [../bin/internal/combine_events] Error 1

Please try to fix this compilations issue and retry.
Help might be found at https://answers.launchpad.net/mg5amcnlo.
If you think that this is a bug, you can report this at https://bugs.launchpad.net/mg5amcnlo
                              Run Options
                              -----------
               stdout_level : 20 (user set)

                         MadEvent Options
                         ----------------
     automatic_html_opening : False (user set)
        notification_center : True
          cluster_temp_path : None
             cluster_memory : None (user set)
               cluster_size : 100
              cluster_queue : None
                    nb_core : 72 (user set)
               cluster_time : 72 (user set)
                   run_mode : 2

                      Configuration Options
                      ---------------------
                text_editor : vi (user set)
         cluster_local_path : None
      cluster_status_update : (600, 30)
               pythia8_path : /data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/HEPTools/pythia8 (user set)
                  hwpp_path : None (user set)
            pythia-pgs_path : None (user set)
                    td_path : None (user set)
               delphes_path : None (user set)
                thepeg_path : None (user set)
               cluster_type : condor
          madanalysis5_path : None (user set)
           cluster_nb_retry : 1
                 eps_viewer : None
                web_browser : None
               syscalc_path : None (user set)
           madanalysis_path : None (user set)
                     lhapdf : /data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/LHAPDF/bin/lhapdf-config (user set)
              f2py_compiler : /cvmfs/cms.cern.ch/slc6_amd64_gcc630/cms/cmssw/CMSSW_9_3_16/external/slc6_amd64_gcc630/bin/f2py (user set)
                 hepmc_path : /data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/HEPTools/hepmc (user set)
         cluster_retry_wait : 300
           fortran_compiler : /cvmfs/cms.cern.ch/slc6_amd64_gcc630/external/gcc/6.3.0/bin/gfortran (user set)
                auto_update : 0 (user set)
        exrootanalysis_path : /data9/Users/shjeon/MadGraph/CMSSW_9_3_16/src/MG5_aMC_v2_6_5/ExRootAnalysis (user set)
                    timeout : 60
               cpp_compiler : None

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
2020-12-21
Last query:
2020-12-21
Last reply:
2020-12-15

Hi,

I actually reproduce the error, it seems that the makefile of this model_v4 need to be updated.
In my case I have the following error message:
     ld: warning: ignoring file ../../lib//libmodel.a, building for macOS-x86_64 but attempting to link with file built for macOS-x86_64

This is not too surprising since makefile of v4 model are static and does not use the flag/... of the rest of the code so it is likely to create issue.
However this does not seem to be exactly your issue since in my case I have such issue for both model.

Don't you have the same model available in the UFO format?

Cheers,

Olivier

Sihyun Jeon (shjeon) said : #2

I found it working at least in MGv260.
But indeed this should be updated (not sure whether UFO is there for us).

Thank you!

Sihyun Jeon (shjeon) said : #3

Thanks Olivier Mattelaer, that solved my question.