Model path problems (list-directed I/O syntax error)

Asked by Ciara Byers on 2020-11-18

Hi,

I've been struggling with some strange errors ever since trying to install madgraph on my university's cluster. I've tried uninstalling, reinstalling, installing a newer version of madgraph but I'm still having the same issue. When I try to run madgraph (after installing the latest version of: boost, lhapdf, pythia and madanalysis sucessfully) it seems to start running, even getting to the first 'current estimate of cross-section' but then prints the following:

forrtl: severe (59): list-directed I/O syntax error, unit 25, file /scratch/cb27g11/TEST_1.0_0.95/SubProcesses/P1_qb_qh1t/G1/ftn25
Image PC Routine Line Source
madevent 0000000000479006 Unknown Unknown Unknown
madevent 00000000004A37E7 Unknown Unknown Unknown
madevent 00000000004590CC Unknown Unknown Unknown
madevent 000000000044C33E Unknown Unknown Unknown
madevent 0000000000440FEA Unknown Unknown Unknown
madevent 0000000000405F43 Unknown Unknown Unknown
madevent 000000000040573E Unknown Unknown Unknown
libc.so.6 000000376981ED20 Unknown Unknown Unknown
madevent 0000000000405649 Unknown Unknown Unknown
rm: cannot remove `results.dat': No such file or directory
ERROR DETECTED

Then it hangs like this until I press ctrl-c multiple times (it tries to run again if I only press it once or twice). I checked ftn26 for the subprocess it was running and I just see a grid of numbers, which I think is what should be there? results.dat is also non-empty,(and indeed, exists!) containing a series of numbers. Both run_01_log.txt and run1_app.log seem to be fine. ME5_debug and MG5_debug are empty.

I have tried both running within a script and running directly from the madgraph interface and I have the same problem. Doing a SM process like p p > Z b b~ , Z > b b~ within the model I am using (2HDMtII_NLO) produces the same effect as BSM processes. This is very confusing as the model works fine on my laptop. I did remove then redownload the model again via the madgraph interface in case it was corrupted somehow, but it didn't fix the problem.

I tried running that same SM process in the SM and I got the same error but more was added onto the end part of the error:

INFO: Idle: 0, Running: 0, Completed: 7 [ 0.072s ]
INFO: Combining runs
Error when reading /scratch/cb27g11/MG5_aMC_v2_7_2/smprocesssm/SubProcesses/P1_gg_zbbx_z_bbx/G1/results.dat
Command "generate_events run_01" interrupted with error:
ValueError : could not convert string to float:
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in '/scratch/cb27g11/MG5_aMC_v2_7_2/smprocesssm/run_01_tag_1_debug.log'.
Please attach this file to your report.

I've double checked that I am running with python2, is there a module I need to load up before running madgraph (since I am running on a cluster)? Python itself seems to be running fine separately.

My colleague asked about this on my behalf a couple of days ago and it was suggested that they run a "input_sg.txt", using madevent, I did this and it produces the same error as before, I can't see any additional hints as to what might be wrong. They also asked for the log.txt file from 'that directory', this file doesn't seem to be generated for me.

Thank-you for reading my very long post, please let me know if you need any further information from me!

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2020-11-19
Last reply:
2020-11-19

This question was reopened

Do I guess correctly that you are using an intel compiler?
Can you try with a gcc compiler?
With which intel compiler version did you try to compile?
We do not have that much experience in intel compiler but I have license from 2017 up to 2019 version so I can give it a try.

Olivier

Ciara Byers (ciarab93) said : #2

No I don't believe I'm using intel. I was unable to install the various HEPTools without explicitly loading the gcc module beforehand. I just tried explicitly loading it again before trying to run a process in madgraph and I have the same errors.

Specifically I'm using gcc 8.2.0

Ciara

Did you regenerate the code?
Otherwise the program being already compiled you will still use intel compiler

Ciara Byers (ciarab93) said : #4

Yes I regenerated the code after explicitly loading gcc, there was no difference. And I had explicitly loaded gcc before installing the current version of madgraph.

Then maybe contact your sys-admin since it does not make sense to have the error:
forrtl: severe (59): list-directed I/O syntax error, unit 25, file /scratch/cb27g11/TEST_1.0_0.95/SubProcesses/P1_qb_qh1t/G1/ftn25
When you do not use intel compiler.

Cheers,

Olivier

Ciara Byers (ciarab93) said : #6

Okay I'll go ahead and do that. Thank-you for your help!

Can you help with this problem?

Provide an answer of your own, or ask Ciara Byers for more information if necessary.

To post a message you must log in.