"Unicode decode error" when launching mg5_aMC

Asked by Nate Thach on 2020-09-24

I am using Ubuntu on a Windows to launch Madgraph on my computer. After untar the package, when I enter "./bin/mg5_aMC" in the terminal, it returned an error message:

"UnicodeDecodeError: 'utf-8' codec can't decode byte 0xff in position 10: invalid start byte". And the same error occurs when I tried to run the ".compile.py" file.

What might have caused the problem? Would it be the compatibility issues on Windows? Thank you in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
2020-09-24
Last query:
2020-09-24
Last reply:
2020-09-24

This error seems to be related to an incoding file error.
The likely issue is that you have some file encoded in latin1 while we always assume utf-8 encoding.

Did you edit one of the configuration file?
Can you check that you did not change the encoding when doing so?

Cheers,

Olivier

PS: I do not have access to a windows computer (I'm still waiting for a license from my university to be able to setup it in a virtual machine).

> On 24 Sep 2020, at 04:50, Nate Thach <email address hidden> wrote:
>
> UnicodeDecodeError: 'utf-8' codec can't decode byte 0xff

Nate Thach (nthach17) said : #2

Thanks Olivier Mattelaer, that solved my question.

Kevin Hutch (kevinhutch) said : #3

Thanks for asking this question i was also facing the similar issue..
and the solution worked for you also worked for me.
visit : https://sawadviser.com/best-corded-jigsaw-reviews/