Problem MG5 on macOS Catalina

Asked by Pim Verschuuren on 2020-09-08

Dear experts,
I have a problem running MG5 since I updated to macOS Catalina (v.10.15.6). I have tried a simple sample generation with v2.6.7, v2.8.0 and v3.0.3 where I got the same error.

After running ./bin/mg5_aMC I only called generate p p > t t~ which after launch produces the following error:

INFO: Update the dependent parameter of the param_card.dat
Generating 10000 events with run name run_01
survey run_01
INFO: compile directory
compile Source Directory
Using random number seed offset = 33
INFO: Running Survey
Creating Jobs
Working on SubProcesses
INFO: P1_gg_ttx
Error detected in "generate_events "
write debug file /Users/pim/Documents/Research/MG5_aMC_v3_0_3/PROC_sm_1/run_01_tag_1_debug.log
If you need help with this issue please contact us on https://answers.launchpad.net/mg5amcnlo
MadGraph5Error : A compilation Error occurs when trying to compile /Users/pim/Documents/Research/MG5_aMC_v3_0_3/PROC_sm_1/SubProcesses/P1_gg_ttx.
 The compilation fails with the following output message:
     gfortran -O -w -fbounds-check -fPIC -ffixed-line-length-132 -w -c symmetry.f -I../../Source/
     gfortran -O -w -fbounds-check -fPIC -ffixed-line-length-132 -w -c idenparts.f -I../../Source/
     gfortran -o gensym symmetry.o idenparts.o -L../../lib/ -lmodel -lgeneric -lpdf -lstdc++
     ld: library not found for -lSystem
     collect2: error: ld returned 1 exit status
     make: *** [gensym] Error 1

Hope you can help me with this.

Kind regards,

Pim

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Pim Verschuuren
Solved:
2020-09-09
Last query:
2020-09-09
Last reply:
2020-09-08

I would advise to uninstall gcc from homebrew and install it from
http://hpc.sourceforge.net/
((just gfortran not gcc)

Otherwise this link might help you: https://github.com/Homebrew/legacy-homebrew/issues/45011

Cheers,

Olivier

> On 8 Sep 2020, at 22:10, Pim Verschuuren <email address hidden> wrote:
>
> ld: library not found for -lSystem

Pim Verschuuren (pverschu) said : #2

Yes that fixed it! Thank you for the fast solution.