Error using modified HC model at NLO with version other than 2.6.6

Asked by Carter Vu on 2020-08-10

Hello MadGraph group,

I am attempting to generate events with a modified HC model at NLO as in https://answers.launchpad.net/mg5amcnlo/+question/685744 with the following process, where x0 is a heavy higgs:

generate p p > w+ x0 > l+ vl l+ vl w- /a [QCD]

the model can be found at:
https://github.com/xuyue1231/MG5-heavy-Higgs/tree/master/HC_NLO_X0_UFO

I can generate successfully in MG5 2.6.6, but in versions 2.55, 2.6.7 and 2.7.3 this command gives the following error:
Command "generate p p > w+ x0 > l+ vl l+ vl w- /a [QCD]" interrupted with error:
NoDiagramException : No amplitudes generated from process Process: g/u/c/d/s/u~/c~/d~/s g/u/c/d/s/u~/c~/d~/s > w+ x0> e+/mu+ ve/vm/vt e+/mu+ ve/vm/vt w- / a QNP=1 WEIGHTED=20 [ noborn = QCD ]. Please enter a valid process.

Are you aware of any reasons this might occur, and what properties of the model we would need to change to resolve this error? Thank you for your help!

Best,
Carter Vu

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2020-08-10
Last reply:
2020-08-10

Hi,

Could you create a tarball of your model,
I'm currently with 4G connection only (due to covid) and not very keen to clone your full repo to get only one of models.

Cheers,

Olivier

> On 10 Aug 2020, at 06:30, Carter Vu <email address hidden> wrote:
>
> New question #692306 on MadGraph5_aMC@NLO:
> https://answers.launchpad.net/mg5amcnlo/+question/692306
>
> Hello MadGraph group,
>
> I am generating events with a modified HC model at NLO as in https://answers.launchpad.net/mg5amcnlo/+question/685744 with the following process, where x0 is a heavy higgs:
>
> generate p p > w+ x0 > l+ vl l+ vl w- /a [QCD]
>
> the model can be found at:
> https://github.com/xuyue1231/MG5-heavy-Higgs/tree/master/HC_NLO_X0_UFO
>
> I can generate successfully in MG5 2.6.6, but in versions 2.6.7 and 2.7.3 this command gives the following error:
> Command "generate p p > w+ x0 > l+ vl l+ vl w- /a [QCD]" interrupted with error:
> NoDiagramException : No amplitudes generated from process Process: g/u/c/d/s/u~/c~/d~/s g/u/c/d/s/u~/c~/d~/s > w+ x0> e+/mu+ ve/vm/vt e+/mu+ ve/vm/vt w- / a QNP=1 WEIGHTED=20 [ noborn = QCD ]. Please enter a valid process.
>
> Are you aware of any reasons this might occur, and what properties of the model we would need to change to resolve this error? Thank you for your help!
>
> Best,
> Carter Vu
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Carter Vu (cartervu) said : #2

Hi Olivier,

Please find attached my tarball in this git repository: https://github.com/cartervu/GHH-Models

Best,
Carter Vu

This is a bug in 2.6.6, the diagram generated are forbidden by the model and the model specify that such diagram should not be include in the computation.

You can change the file
coupling_orders.py and change the line

# NEW
QNP = CouplingOrder(name = 'QNP',
                    hierarchy = 2,
                    expansion_order = 1,
                    perturbative_expansion = 0)

to

# NEW
QNP = CouplingOrder(name = 'QNP',
                    hierarchy = 2,
                    expansion_order = -1,
                    perturbative_expansion = 0)

To allow MG5aMC to include feynman diagram with more than one insertion.

Cheers,

Olivier

> On 10 Aug 2020, at 17:25, Carter Vu <email address hidden> wrote:
>
> Question #692306 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/692306
>
> Status: Answered => Open
>
> Carter Vu is still having a problem:
> Hi Olivier,
>
> Please find attached my tarball in this git repository:
> https://github.com/cartervu/GHH-Models
>
> Best,
> Carter Vu
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Can you help with this problem?

Provide an answer of your own, or ask Carter Vu for more information if necessary.

To post a message you must log in.