Delphes installation with MG5 v2.7.3 py3

Asked by Sebastian Urrutia-Quiroga on 2020-07-17

Hi all,

I recently downloaded the latest MG5 version compatible with Python3 (2.7.3-py3) and I tried to install Delphes by running the option "install Delphes". I always use this method to install Delphes but this time I got an error:

compile Delphes. This might take a while.
>> Generating tmp/classes/ClassesDict.cc
In file included from input_line_14:1:
In file included from /Users/surrutiaquir/miniconda3/include/TStreamerInfo.h:21:
In file included from /Users/surrutiaquir/miniconda3/include/TVirtualCollectionProxy.h:26:
In file included from /Users/surrutiaquir/miniconda3/include/TClassRef.h:24:
In file included from /Users/surrutiaquir/miniconda3/include/TClass.h:31:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/unordered_set:367:
/Users/surrutiaquir/Documents/Programs/MG5_aMC_v2_7_3_py3/Delphes/version:1:1: error: expected unqualified-id
3.4.2
^
In file included from input_line_14:2:
In file included from /Users/surrutiaquir/miniconda3/include/TFile.h:33:
In file included from /Users/surrutiaquir/miniconda3/include/ROOT/TRWSpinLock.hxx:19:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/condition_variable:110:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/__mutex_base:14:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/chrono:801:
/Users/surrutiaquir/Documents/Programs/MG5_aMC_v2_7_3_py3/Delphes/version:1:1: error: expected unqualified-id
3.4.2
^
In file included from input_line_14:2:
In file included from /Users/surrutiaquir/miniconda3/include/TFile.h:34:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/mutex:197:
/Users/surrutiaquir/Documents/Programs/MG5_aMC_v2_7_3_py3/Delphes/version:1:1: error: expected unqualified-id
3.4.2
^
In file included from input_line_14:18:
In file included from /Users/surrutiaquir/miniconda3/include/root_std_complex.h:13:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/complex:246:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/sstream:173:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/ostream:140:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/locale:189:
/Users/surrutiaquir/Documents/Programs/MG5_aMC_v2_7_3_py3/Delphes/version:1:1: error: expected unqualified-id
3.4.2
^
In file included from input_line_14:18:
In file included from /Users/surrutiaquir/miniconda3/include/root_std_complex.h:13:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/complex:246:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/sstream:173:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/ostream:143:
/Users/surrutiaquir/Documents/Programs/MG5_aMC_v2_7_3_py3/Delphes/version:1:1: error: expected unqualified-id
3.4.2
^
In file included from input_line_14:18:
In file included from /Users/surrutiaquir/miniconda3/include/root_std_complex.h:13:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/complex:246:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/sstream:174:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/istream:162:
/Users/surrutiaquir/Documents/Programs/MG5_aMC_v2_7_3_py3/Delphes/version:1:1: error: expected unqualified-id
3.4.2
^
In file included from input_line_14:18:
In file included from /Users/surrutiaquir/miniconda3/include/root_std_complex.h:13:
In file included from /Users/surrutiaquir/miniconda3/bin/../include/c++/v1/complex:247:
/Users/surrutiaquir/Documents/Programs/MG5_aMC_v2_7_3_py3/Delphes/version:1:1: error: expected unqualified-id
3.4.2
^
make: *** [tmp/classes/ClassesDict.cc] Error 1
Error detected during the compilation. Please check the compilation error and run make manually.

Do you know what would be causing this? Any help is welcome!

Thanks a lot,
Sebastian

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
2020-07-30
Last query:
2020-07-30
Last reply:
2020-07-29

No clue,
I guess that you should ask the Delphes author since this does not sounds a python related error.
Note that you can just edit the file input/mg5_configuration.txt
to link to another version of Delphes (if you have a previous installation that was working)

Cheers,

Olivier

Thanks Olivier Mattelaer, that solved my question.