pythia8 return code

Asked by vickersmt on 2020-07-09

Hi all,
I'm having some issues with Madgraph and Pythia
when i opened the mg5 and start to type:
  generate e+ e- > k+ k-
  add process e+ e- > k+ k- g
k is defined by myself conclude u d s c b

when i start to launch,the bug comes out:

INFO: Running Pythia8 [arXiv:1410.3012]
No user-defined value for Pythia8 parameter 'JetMatching:nJetMax'. Setting it automatically to 1.
Follow Pythia8 shower by running the following command (in a separate terminal):
    tail -f /home/surrutia/madgraph/signal_e-e-2j/Events/run_01/tag_1_pythia8.log
Command "generate_events run_01" interrupted with error:
InvalidCmd : Pythia8 shower interrupted with return code 139.
        You can find more information in this log file:
        /home/download/madgraph/a23p/Events/run_01/tag_1_pythia8.log

In the mentioned log file, I found the following message:

/home/surrutia/madgraph/signal_e-e-2j/Events/run_01/run_shower.sh: line 2: 29494 Segmentation fault (core dumped) LD_LIBRARY_PATH=/home/surrutia/madgraph/HEPTools/MG5aMC_PY8_interface/MG5aMC_PY8_interface tag_1_pythia8.cmd

i don't know where the problem is , it's OK when i generate e+ e-> k+ k- or generate e+ e->k+ k- g
but when i used the "add process",the problem comes.

Thanks,
Vickers

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
Stefan Prestel Edit question
Solved by:
Olivier Mattelaer
Solved:
2020-07-09
Last query:
2020-07-09
Last reply:
2020-07-09

You should contact Pythia8 author about this.

The issue might be solve if you use the latest version of pythia8, but we can not install it yet with the "install pythia8" command due to some error at the installation.

Cheers,

Olivier

vickersmt (vickersccj) said : #2

Thanks Olivier Mattelaer, that solved my question.