Neutralino width set to 0 for consistency

Asked by Emily Thompson on 2020-06-30

Hi,

I am trying to generate the RPV SUSY process: p p > go go using the MSSM_SLHA2 model in MadGraph 2.6.7 + Pythia 8. The gluinos decay to a neutralino + SM quarks, and the neutralino decays via an RPV coupling to SM quarks. When I set the width of the neutralino so that it has a non-zero lifetime (like 0.01 ns, for example), then the event generation works as expected and the neutralino has the desired lifetime. However if I increase the width of the neutralino to 1.0 so that it decays promptly, MadGraph gives me the following warning,

WARNING: For consistency, the width of particle 1000022 (n1) is changed to 0.0.

, and the neutralino becomes stable. It seems that setting the neutralino width above ~ 1E-5 causes MadGraph to change the width to 0, while any width below this it leaves unchanged.

I would like to know why this is happening? And how I can produce events with promptly-decaying neutralinos?

Thank you,
Emily Thompson

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
2020-07-01
Last query:
2020-07-01
Last reply:
2020-06-30

Hi,

In principle you should have that message for any value of the width.
But in practise this warning only occurs above a given threshold.

The point is that the model that you use HARDCODE that width to zero, setting a value different of zero can lead to unphysical behaviour/ inconsistencies.

If you want to set that width to a different value, you need to use another model.
(maybe MSSM_SLHA2-full is enough)

Cheers,

Olivier

> On 30 Jun 2020, at 14:45, Emily Thompson <email address hidden> wrote:
>
> New question #691605 on MadGraph5_aMC@NLO:
> https://answers.launchpad.net/mg5amcnlo/+question/691605
>
> Hi,
>
> I am trying to generate the RPV SUSY process: p p > go go using the MSSM_SLHA2 model in MadGraph 2.6.7 + Pythia 8. The gluinos decay to a neutralino + SM quarks, and the neutralino decays via an RPV coupling to SM quarks. When I set the width of the neutralino so that it has a non-zero lifetime (like 0.01 ns, for example), then the event generation works as expected and the neutralino has the desired lifetime. However if I increase the width of the neutralino to 1.0 so that it decays promptly, MadGraph gives me the following warning,
>
> WARNING: For consistency, the width of particle 1000022 (n1) is changed to 0.0.
>
> , and the neutralino becomes stable. It seems that setting the neutralino width above ~ 1E-5 causes MadGraph to change the width to 0, while any width below this it leaves unchanged.
>
> I would like to know why this is happening? And how I can produce events with promptly-decaying neutralinos?
>
> Thank you,
> Emily Thompson
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Emily Thompson (eat4978) said : #2

Thanks for your quick reply. Using the RPVMSSM_UFO model has solved the issue.

Emily Thompson (eat4978) said : #3

Thanks Olivier Mattelaer, that solved my question.