Increase event count

Asked by Chuck on 2020-06-22

Is there a way to increase the number of weighted events that are produced before the unweighting procedure?

When running with the set of cuts I desire and request 20,000 unweighted events, but get anywhere from 5,000 to 20,000 events. Most frequently, I get about 11,000 events. However, if I make one of the pT cuts a little looser, I am able to generate 20,000 events every time. Based on the warning messages, it seems like it's just running out of weighted events to accept/reject when it's performing the unweighting routine.

Or, if there is a better solution, I would love to hear.

Question information

English Edit question
MadGraph5_aMC@NLO Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:


Yes this is possible but you need to have the latest version of the code (2.7.3) release yesterday (2.7.2 has a similar option but it changed in 2.7.3 so I only describe the 2.7.2 one).

You have to set in the run_card the line
X = hard_survey

0 is the normal mode, higher value means longer code (This does not only impact the maximum of weighted events but also a bunch of other parameter to increase the security of the integration for such difficult integral). Setting too high value here can lead to very very long cpu time (even for very simple process)



Chuck (cburton12) said : #2

Hi Olivier,

Thank you for the info. Unfortunately, I can't upgrade my software version since I am using MadOnia, which I've read only works with MadGraph4. I assume there's not a flag like this in MadGraph4?

My backup plan was just to set nevents to 40,000 instead, so that I get enough unweighted events in the output LHE.



What I would suggest then is to edit the file:
and search for a line
c Here we will double the number of events requested for the next run
 23 events = 2 * events
 (those are taken from 2.7.3 but I think that such lines were not modified since MadGraphII)

and I would replace it by
c Here we will double the number of events requested for the next run
 23 events = 3 * events

Now my level of knowledge of MadOnia is such that, I'm not even sure if it use that file.
So it might not have an impact.

Chuck (cburton12) said : #4

This suggestion appears to work. Thank you.

Chuck (cburton12) said : #5

This is just a quick follow up. After doing some more digging, it seems like there was a deeper issue. There is a bug in MadOnia which appears when one runs with QCD=99 and QED=99. The cross sections for each subprocess do not make sense. If one generates events for QCD and QED production separately (in my case by setting QCD=1 QED=3, and then QCD=2 QED=1), this bug can be avoided.

I discovered that, once this issue is accounted for, the output unweighted event count is always the requested number.

I don't expect that many are still using MG4, but I figured I would just add this comment in case anyone in the future is using MadOnia and runs into this issue.