Particle names not recognised when running MadSpin

Asked by Luca Panizzi on 2020-05-19

Hi,
I am running processes with the model dmsimpt_v1.2 (t-channel DM simplified models) and I am getting error messages when running MadSpin, not being able to recognise some particle names.

Specifically, after importing the model via the command

import model DMSimp_t-F3S_uR --modelname

and generating events for the process:

define yy = yf3u1 yf3u1~
define excl = yf3qu1 yf3qu2 yf3qu3 yf3qd1 yf3qd2 yf3qd3 yf3u2 yf3u3 yf\
3d1 yf3d2 yf3d3 ys3qu1 ys3qu2 ys3qu3 ys3qd1 ys3qd2 ys3qd3 ys3u1 ys3u2 \
ys3u3 ys3d1 ys3d2 ys3d3 xc xd xm xv xw a z
generate p p > yy yy DMT^2==2 / excl

Giving the following commands in the MadSpin card:
set spinmode none
decay yf3u1 > xs u
decay yf3u1~ > xs u~

MadSpin complains that it cannot recognise particles which share the same PDG code as SUSY particles (all the coloured scalar mediators) and returns this message:

Command "decay_events MY500_MX150 " interrupted with error:
InvalidCmd : No particle ys3qu1 in model

I have digged a bit into the MadGraph/MadSpin files and found that the following lines of the function do_import in madgraph_interface.py:

if '-modelname' not in args:
                self._curr_model.pass_particles_name_in_mg_default()

are applied and the above particles are not recognised anymore.

Indeed, the arguments of the function do not contain the string "--modelname"; if I print the args variable I obtain:

['model', '/home/panizzi/Research/MadGraph/MG5_aMC_v2_6_3_2/models/DMSimp_t-F3S_uR']

As a temporary workaround I have commented the previous lines, and MadSpin works. But I wonder why the arguments are not passed properly and what can be a better solution.

I am using MG v 2.6.3.2 but I could reproduce the same error with 2.6.7 and 2.7.2

Hope the information I provided help to reproduce the error, but let me know if you need cards or further info.

Thank you.
Luca

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Luca Panizzi
Solved:
2020-05-20
Last query:
2020-05-20
Last reply:
2020-05-20

Dear Luca,

Unfortunately, I do not reproduce your error locally (with 2.7.2).

Also your bug does not make sense to me.
If you look at MadSpin, the way he is loading the model is at line 1136:

        # Import model
        base_model = import_ufo.import_model(name, decay=True,
                                               complex_mass_scheme=complex_mass)

        if use_mg_default:
            base_model.pass_particles_name_in_mg_default(

So it is NOT using the line that you modified.
If you look inside madspin.py, You will find two call to "import model" function from madgraph.interface.madgraph_interface.py
but those are related to the onshell mode.

To fully confirm this, I have add a print statement in madgraph.interface.madgraph_interface.py in the do_import function
and indeed madspin does not call that function at all.

This does not make sense with the fact that commenting the above line fixes the issue. (But if you do not have the same issue in 2.7.2 as the one in 2.6.3.2)

Maybe you could convert this to a bug report which will allow you to put attachments.
I would need to have your UFO model and the debug file.

Cheers,

Olivier

Luca Panizzi (lcpnzz) said : #2

Hi Olivier,
I have moved the question to the bug reports indeed. I labelled it as problem solved here, for the moment.

Cheers,
Luca