parameter scan fails after complaining about 3 body decay

Asked by Jan Hajer on 2020-05-15

Hi Olivier,

I am running a 2 dim parameter scan using a heavy Neutrino model file.
My scan used to run fine in the past but now (2.7.2) it stops after two points.
Both points give me an exception:
Exception : Phase Space generator not yet ready for 3 body decay

Do you have any idea how I can debug this?

I modified the phase space.
But also unmodified scripts fails.
My script starts with:

import model ../mg5amcnlo/models/SM_HeavyN_NLO
define lep = e+ e- mu+ mu- ta+ ta-
define ferm = lep ve ve~ vm vm~ vt vt~ u u~ d d~ s s~ c c~ b b~
generate p p > ferm n1
output out
launch out
shower = PY8
madspin = none
decay n1 > ferm ferm ferm
set ebeam1 7000
set ebeam2 7000
set nevents 10000
set ptl 0
set etal -1.49
set etalmin -3.44
set drll 0
set mpi False
set use_syst False
set time_of_flight 0.1
set mN2 1000000
set mN3 1000000
set VeN1 0
set VtaN1 0
set VeN2 0
set VmuN2 0
set VtaN2 0
set VeN3 0
set VmuN3 0
set VtaN3 0
# U2 0.010000000000000002
# M 1.
set mN1 1.
set VmuN1 0.1
compute_widths --body_decay=3.0025 n1
launch
# U2 0.0016681005372000592
# M 1.
set mN1 1.
set VmuN1 0.04084238652674522
compute_widths --body_decay=3.0025 n1
launch
# U2 0.00027825594022071263
# M 1.
set mN1 1.
set VmuN1 0.016681005372000592
compute_widths --body_decay=3.0025 n1
launch
# U2 0.00004641588833612792
# M 1.
set mN1 1.
set VmuN1 0.006812920690579622
compute_widths --body_decay=3.0025 n1
launch
# U2 7.742636826811277e-6
# M 1.
set mN1 1.
set VmuN1 0.0027825594022071257
compute_widths --body_decay=3.0025 n1

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Jan Hajer
Solved:
2020-05-15
Last query:
2020-05-15
Last reply:
2020-05-15

Hi Jan,

I did not reproduce the issue when I run those commands.

The crash seems related to the fact that you try to run madspin in standard mode and not in "none" as you request it.

I can see two reasons:
1) you edit (outside of the script) the madspin_card flipping back madspin to the standard mode
2) your initial madspin card was in a non standard state making the automatic modification of the card not working. (like if you have two line set spinmode XXXXX in your madspin_card)

Could you paste your madspin_card here?

Cheers,

Olivier

> On 15 May 2020, at 16:41, Jan Hajer <email address hidden> wrote:
>
> Phase Space generator not yet ready for 3 body decay

Jan Hajer (jan.hajer) said : #2

Hi Olivier,

I try to make no changes to madgraph outside of my script.
Even the folders containing my scripts and the results are outside of the madgraph tree.
The madspin_card.dat (without header) in my results folder is:

# set seed 1
# set Nevents_for_max_weigth 75 # number of events for the estimate of the max. weight
# set BW_cut 15 # cut on how far the particle can be off-shell
# set spinmode onshell # Use one of the madspin special mode
 set max_weight_ps_point 400 # number of PS to estimate the maximum for each event

# specify the decay for the final state particles
decay t > w+ b, w+ > all all
decay t~ > w- b~, w- > all all
decay w+ > all all
decay w- > all all
decay z > all all
# running the actual code

decay n1 > ferm ferm ferm
launch

Cheers,
Jan

Hi,

so you indeed miss the line
 set spinmode none
which should have been inserted because of the
> madspin = none
line in your script.

Do you have any warning in your log?

Cheers,

Olivier

> On 15 May 2020, at 19:35, Jan Hajer <email address hidden> wrote:
>
> Question #690738 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/690738
>
> Status: Answered => Open
>
> Jan Hajer is still having a problem:
> Hi Olivier,
>
> I try to make no changes to madgraph outside of my script.
> Even the folders containing my scripts and the results are outside of the madgraph tree.
> The madspin_card.dat (without header) in my results folder is:
>
> # set seed 1
> # set Nevents_for_max_weigth 75 # number of events for the estimate of the max. weight
> # set BW_cut 15 # cut on how far the particle can be off-shell
> # set spinmode onshell # Use one of the madspin special mode
> set max_weight_ps_point 400 # number of PS to estimate the maximum for each event
>
> # specify the decay for the final state particles
> decay t > w+ b, w+ > all all
> decay t~ > w- b~, w- > all all
> decay w+ > all all
> decay w- > all all
> decay z > all all
> # running the actual code
>
> decay n1 > ferm ferm ferm
> launch
>
>
> Cheers,
> Jan
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Jan Hajer (jan.hajer) said : #4

Hi,

the log file contains no mention of madspin beside the traceback.
However the terminal output contains the lines:

found line : decay n1 > ferm ferm ferm
This answer is not valid for current question. Keep it for next question and use here default: EOF
INFO: Replacing the line " set spinmode none" [line 22 of madspin_card.dat] by " set spinmode none"
DEBUG: not keep in sync: madspin_card.dat
decay n1 > ferm ferm ferm
INFO: change madspin_card to define the decay of n1: n1 > ferm ferm ferm
DEBUG: not keep in sync: /nfs/scratch/fynu/hajer/results/MAPP_1/Cards/madspin_card.dat

Cheers,
Jan

Hi,

I do not have the exact same lines:

> found line : decay n1 > ferm ferm ferm
> This answer is not valid for current question. Keep it for next question and use here default: EOF
> INFO: writting at line 22 of the file madspin_card.dat the line: "set spinmode none"
> DEBUG: not keep in sync: /Users/omattelaer/Documents/workspace/2.7.3/out/Cards/madspin_card.dat
> decay n1 > ferm ferm ferm
> INFO: change madspin_card to define the decay of n1: n1 > ferm ferm ferm
> DEBUG: not keep in sync: /Users/omattelaer/Documents/workspace/2.7.3/out/Cards/madspin_card.dat
> set ebeam1 7000
> INFO: modify parameter ebeam1 of the run_card.dat to 7000.0

But the line where the spinmode is set is the same one.
This shows that your madspin_card was already modified.
But this does not explains the issue at all (on the contrary).

Sorry I have no idea of what can cause this.
Do you run this script on ingrid?

Cheers,

Olivier

> On 15 May 2020, at 20:45, Jan Hajer <email address hidden> wrote:
>
> Question #690738 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/690738
>
> Status: Answered => Open
>
> Jan Hajer is still having a problem:
> Hi,
>
> the log file contains no mention of madspin beside the traceback.
> However the terminal output contains the lines:
>
> found line : decay n1 > ferm ferm ferm
> This answer is not valid for current question. Keep it for next question and use here default: EOF
> INFO: Replacing the line " set spinmode none" [line 22 of madspin_card.dat] by " set spinmode none"
> DEBUG: not keep in sync: madspin_card.dat
> decay n1 > ferm ferm ferm
> INFO: change madspin_card to define the decay of n1: n1 > ferm ferm ferm
> DEBUG: not keep in sync: /nfs/scratch/fynu/hajer/results/MAPP_1/Cards/madspin_card.dat
>
>
> Cheers,
> Jan
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Jan Hajer (jan.hajer) said : #6

Hi,

I have reinstalled MadGraph now it seems to run smoothly.

Thank you for double checking my script!
Cheers,
Jan