Delphes compilation error

Asked by Smita Darmora on 2019-11-25

I am trying to install Delphes. I installed successfully MG5_aMC_v2_6_7 and Pythia. But, I am finding problem in compiling Delphes. Using 'make' command gives the following error :

 make
ProMC event reader is requested
make: Circular external/fastjet/JetDefinition.hh <- external/fastjet/ClusterSequence.hh dependency dropped.
>> Building hepmc2pileup
/blues/gpfs/home/software/spack-0.10.1/opt/spack/linux-centos7-x86_64/intel-17.0.4/binutils-2.31.1-66nrgovmbjo2hp26sdjf6umcnzuclqim/bin/ld: /blues/gpfs/home/software/spack-0.10.1/opt/spack/linux-centos7-x86_64/intel-17.0.4/libpng-1.6.34-nhq7uj3wpe5gparrnnq2lrvmxz4g7l4b/lib/libpng16.so.16: undefined reference to `inflateValidate@ZLIB_1.2.9'
collect2: error: ld returned 1 exit status
make: *** [hepmc2pileup] Error 1

======================================
MG5_aMC_v2_6_7
ROOT is 6.12/04 Built for linuxx8664gcc
OS: Centos Linux
version: 7 (core)

Best,
Smita

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-25
Last reply:
2019-11-25

Not sure I can help on that.
The Delphes author would be more able to help you on how to install their code.

I can just point this thread which seems to provide help:

https://github.com/stereolabs/zed-opencv/issues/58

Cheers,

Olivier

Can you help with this problem?

Provide an answer of your own, or ask Smita Darmora for more information if necessary.

To post a message you must log in.