High accuracy run ends with non zero status

Asked by Cameron Voisey

Dear developers,

I am running MG5 to produce p p > l- l+ invariant mass histograms at LO in Fixed-Order mode in the 5 flavour scheme. When doing this recently I got the following warnings which stopped the computation:

INFO: Idle: 0, Running: 2, Completed: 176 [ 69h 59m ]
INFO: Idle: 0, Running: 1, Completed: 177 [ 70h 32m ]
INFO: Idle: 0, Running: 0, Completed: 178 [ 71h 44m ]
     Current results:
     Total cross section: 2.457e+02 +- 3.0e-03 pb

INFO: Refining results, step 4
WARNING: program /store/DAMTP/cv331/MG5_aMC_v2_6_6/AFB_nophoton_8tev_muons/SubProcesses/P0_uux_mummup/ajob1 1 born 2 4 launch ends with non zero status: 2. Stop all computation
WARNING: program /store/DAMTP/cv331/MG5_aMC_v2_6_6/AFB_nophoton_8tev_muons/SubProcesses/P0_uux_mummup/ajob1 1 born 3 4 launch ends with non zero status: 2. Stop all computation
INFO: Idle: 117, Running: 0, Completed: 60 [ current time: 15h27 ]

I ran a very similar run previously which ran without issue. Between runs I changed (i) req_acc and req_acc_FO from 0.0001 to 0.000002, (ii) I changed ebeam1 and ebeam2 from 6500.0 to 4000.0, and (iii) I defined l- = mu-, l+ = mu+, whereas before I used the default lepton definitions. Perhaps the issue could be caused by the fact that I am requiring a very high accuracy?

Not that this is the proc_card_mg5.dat that I'm using:

#* *
#* * * *
#* * * * * *
#* * * * * 5 * * * * *
#* * * * * *
#* * * *
#* *
#* *
#* VERSION 2.6.6 2018-06-28 *
#* *
#* The MadGraph5_aMC@NLO Development Team - Find us at *
#* https://server06.fynu.ucl.ac.be/projects/madgraph *
#* *
#* *
#* Command File for MadGraph5_aMC@NLO *
#* *
#* run as ./bin/mg5_aMC filename *
#* *
set default_unset_couplings 99
set group_subprocesses Auto
set ignore_six_quark_processes False
set loop_optimized_output True
set loop_color_flows False
set gauge unitary
set complex_mass_scheme False
set max_npoint_for_channel 0
import model sm
define p = g u c d s u~ c~ d~ s~
define j = g u c d s u~ c~ d~ s~
define l+ = e+ mu+
define l- = e- mu-
define vl = ve vm vt
define vl~ = ve~ vm~ vt~
import model sm-no_b_mass
define p = 21 2 4 1 3 -2 -4 -1 -3 5 -5 # pass to 5 flavors
define j = p
define p = p b b~
define l- = mu-
define l+ = mu+
generate p p > l- l+ [LOonly]
output AFB_nophoton_8tev_muons

To investigate this I went to one of the problematic directories (/store/DAMTP/cv331/MG5_aMC_v2_6_6/AFB_nophoton_8tev_muons/SubProcesses/P0_uux_mummup) and opened both log files. I found two log files: gensym.log and test_ME.log. The latter had no problems but at the bottom of the former I found this:

 alpha_s= 0.11801575824736407
 born momenta
   1 0.29524E+02 0.00000E+00 0.00000E+00 0.29524E+02
   2 0.29524E+02 -0.00000E+00 -0.00000E+00 -0.29524E+02
   3 0.29524E+02 0.28240E+02 0.80800E+01 -0.29783E+01
   4 0.29524E+02 -0.28240E+02 -0.80800E+01 0.29783E+01
 Bad swap 1 2 4 3
 Found 0 matches. 2 channels remain for integration.

I'm not sure what 'Bad swap' means or whether this could be causing the problem. Do you have any idea of what the problem could be? Any help with this would be very much appreciated!

Best wishes,

Question information

English Edit question
Needs information
MadGraph5_aMC@NLO Edit question
marco zaro Edit question
Last query:
Last reply:
Revision history for this message
marco zaro (marco-zaro) said :

Hi Cameron,
thanks for contacting us.
Bad swap in the gensym.log is nothing to worry about.
I would ask you to check the logs in the born_GB** directories, in particular log_MINT1.txt.
Can you please send the last few lines?


Best wishes,


Revision history for this message
Cameron Voisey (cameron.voisey) said :

Hi Marco,

Thanks very much for your response. I just realised that in the same directory I stupidly launched a run with a lower accuracy to see if this worked, and since the files you refer to are not in a folder that is specific to each run, I guess the information you are referring to has been overwritten?

Best wishes,

Revision history for this message
marco zaro (marco-zaro) said :

right, so unfortunately you need to redo the high-accuracy run again..

Let me know

Best wishes,


Can you help with this problem?

Provide an answer of your own, or ask Cameron Voisey for more information if necessary.

To post a message you must log in.