Error in generating events

Asked by Ekaterina on 2019-10-12

Hello dear experts!

I am having a problem generating events in MadGraph.
 In the LanHEP package, I created a new model. In this model, a doubly charged particle X decays into two positrons and a gamma.

This is what I have in LanHEP:

model DMsimplescalar/1.
scalar x/X : ('X', mass MX1=1000, pdg 9000008).
spinor 'e-'/'e+' : ('Electron', pdg 11 ).
vector A/A : ('Photon',gauge).
parameter a1=1,b1=1,EE = 0.31333 : 'Electromagnetic coupling constant (<->1/128)'.

lterm X*anti(cc('e-'))*(a1+b1*gamma5)*'e+' + AddHermConj.
lterm -EE*A*x*deriv*X+ AddHermConj.
lterm -EE*'e-'*gamma*'e+'*A.

Next, I got the file in UFO format.
 In MadGraph, I import my model and generated events.

MG5_aMC>import model
MG5_aMC> generate x > e+ e+ a
MG5_aMC> output
MG5_aMC> launch

 Further after the launch command, I get the following message

Command "generate_events run_01" interrupted with error:
KeyError : 'ZERO'
More information is found in 'ME5_debug'.

Ca i send you the ME5_debug file?
What could be the mistake here?

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
2019-10-14
Last query:
2019-10-14
Last reply:
2019-10-12

attachment are only possible for bug report (so please create a bug report)

The KeyError ZERO is something that I have never seen before but it is likely linked to the model. So When I will have a bit more detail on what's going on, I will likely tell you to contact LanHep author in order to ask them to fix the model.

Cheers,

Olivier

> On 12 Oct 2019, at 20:27, Ekaterina <email address hidden> wrote:
>
> New question #685050 on MadGraph5_aMC@NLO:
> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fanswers.launchpad.net%2Fmg5amcnlo%2F%2Bquestion%2F685050&amp;data=02%7C01%7C%7Cfb879cd2c4cb4e03d9bf08d74f41d8ff%7C7ab090d4fa2e4ecfbc7c4127b4d582ec%7C0%7C0%7C637065017022582324&amp;sdata=WWK4zTGYpWQZA92uQn4puQTVy%2FSCNvT%2FBIofKG8xQLM%3D&amp;reserved=0
>
> Hello dear experts!
>
> I am having a problem generating events in MadGraph.
> In the LanHEP package, I created a new model. In this model, a doubly charged particle X decays into two positrons and a gamma.
>
> This is what I have in LanHEP:
>
> model DMsimplescalar/1.
> scalar x/X : ('X', mass MX1=1000, pdg 9000008).
> spinor 'e-'/'e+' : ('Electron', pdg 11 ).
> vector A/A : ('Photon',gauge).
> parameter a1=1,b1=1,EE = 0.31333 : 'Electromagnetic coupling constant (<->1/128)'.
>
> lterm X*anti(cc('e-'))*(a1+b1*gamma5)*'e+' + AddHermConj.
> lterm -EE*A*x*deriv*X+ AddHermConj.
> lterm -EE*'e-'*gamma*'e+'*A.
>
> Next, I got the file in UFO format.
> In MadGraph, I import my model and generated events.
>
> MG5_aMC>import model
> MG5_aMC> generate x > e+ e+ a
> MG5_aMC> output
> MG5_aMC> launch
>
> Further after the launch command, I get the following message
>
> Command "generate_events run_01" interrupted with error:
> KeyError : 'ZERO'
> More information is found in 'ME5_debug'.
>
> Ca i send you the ME5_debug file?
> What could be the mistake here?
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Ekaterina (happykate10) said : #2

Thanks Olivier Mattelaer, that solved my question.