Error detected in "generate_events run_01"

Asked by Andres Abreu on 2019-09-14

Hello I just installed Madgraph 5 and when I try to run it the first time I get:

Error detected in "generate_events run_01"
write debug file /Users/andres/HEP_Tools/MG5_aMC_v2_6_6/PROC_sm_3/run_01_tag_1_debug.log
If you need help with this issue please contact us on https://answers.launchpad.net/mg5amcnlo
MadGraph5Error : A compilation Error occurs when trying to compile /Users/andres/HEP_Tools/MG5_aMC_v2_6_6/PROC_sm_3/SubProcesses/P1_gg_ttx.
 The compilation fails with the following output message:
     gfortran -O -w -fbounds-check -fPIC -ffixed-line-length-132 -w -c symmetry.f -I../../Source/
     gfortran -O -w -fbounds-check -fPIC -ffixed-line-length-132 -w -c idenparts.f -I../../Source/
     gfortran -o gensym symmetry.o idenparts.o -L../../lib/ -lmodel -lgeneric -lpdf -lstdc++
     collect2: fatal error: ld terminated with signal 10 [Bus error: 10]
     compilation terminated.
     ld: unexpected token: !tapi-tbd-v3 file '/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib/libSystem.tbd' for architecture x86_64
     make: *** [makefile:47: gensym] Error 1

 Please try to fix this compilations issue and retry.
 Help might be found at https://answers.launchpad.net/mg5amcnlo.
 If you think that this is a bug, you can report this at https://bugs.launchpad.net/mg5amcnlo

I'm running on Mac OSX 10.14.6. I have gcc version 4.2.1 and gfortran 9.2.0.

I tried some of the suggestions for similar problems but I just can't get MG5 to work. Any help would be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Andres Abreu
Solved:
2019-09-14
Last query:
2019-09-14
Last reply:
2019-09-14

Hi,

This does not seems to be related to MG5aMC at all.
I have found the following topic when googling your error:
https://trac.macports.org/ticket/58333#comment:8

They propose some way to fix the issue.
Cheers,

Olivier

On 14 Sep 2019, at 05:42, Andres Abreu <<email address hidden><mailto:<email address hidden>>> wrote:

 ld: unexpected token: !tapi-tbd-v3 file '/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib/libSystem.tbd' for architecture x86_64

Andres Abreu (andrestoeu) said : #2

Hi olivier,

Not entirely sure what my problem was but that fixed it perfectly!

Thanks!

Andrés