Problem with importing a model

Asked by Maksym Ovchynnikov on 2019-06-20

I have a model Model adding a new vector boson X interacting with two W bosons (with InteractionOrder -> {NP, 1}). The information in particles.oy about X is the following:

xb = Particle(pdg_code = 9000005,
              name = 'xb',
              antiname = 'xb',
              spin = 3,
              color = 1,
              mass = Param.Mxb,
              width = Param.Wxb,
              texname = 'xb',
              antitexname = 'xb',
              charge = 0,
              GhostNumber = 0,
              LeptonNumber = 0,
              Y = 0)

When I write add model Model, xb is not present among the particles! However, if I write import model Model, the xb is present among the particles, but all the processes fail to run saying Error 1.
How to fix this issue?

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
2019-06-21
Last query:
2019-06-21
Last reply:
2019-06-20

Is this the error that you face?

For the add model XXX test, I would need your model in order to see what's going on.
Can you put it online somewhere (or send it to the following email <email address hidden> with a link to this thread)

Cheers,

Olivier
FAQ #2460: “How to fix: “Command “generate X X > Y Y Y” interrupted with error: KeyError : '1'”.

Thanks for the model,

The issue is that particle with identical pdg code are merged.
Your xb particles use the same pdg code as the ghost particle associated to the gluon.
and therefore your particle is not added since it already exists in the orignal model. (and we keep that name)

It would make sense to crash here since the property (spin/...) are not identical.
So changing that pdg code will solve that issue.

This being said the idea for "add model" is to have quite minimal model which does not seems to be the case of yours.

Cheers,

Olivier

Maksym Ovchynnikov (name-xxx) said : #3

Thanks Olivier Mattelaer, that solved my question.