MadSpin error for MSSM@NLO process

Asked by jackaraz on 2018-11-30

Hi Oliver

I'm trying to calculate gluino production @NLO for MSSM and then decay it to 2j+MET with madspin. Thus I follow this procedure;

generate p p > go go [QCD]

first I tried to define squarks as

define sq = b1 b1~ b2 b2~ dl dl~ dr dr~ sl sl~ sr sr~ ul ul~ cl cl~
 and then I defined them both in madspin card and before generating the event then tried to decay gluinos as

decay go > sq j
decay sq > j n1

but it did not recognize sq and gave the following error;

Command "launch auto " interrupted with error:
KeyError : 'sq'

Thus I tried set spinmode none (rest is the same) then I got

CRITICAL: Branching ratio larger than one for 1000021
Command "launch auto " interrupted with error:
ZeroDivisionError : float division by zero

then instead of using sq, I used all. With spinmode none, I got the same error as above and without I got

Command "launch auto " interrupted with error:
MadGraph5Error : No valid decay for 1000021. No 2 body decay for that particle. (three body are not supported by MadSpin)

I couldn't understand what am I doing wrong here. Do you think there is a problem with the model that I'm using or am I missing something in the process itself.

Thank you very much
Jack

Question information

Language:
English Edit question
Status:
Needs information
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2018-12-03
Last reply:
21 hours ago

Hi,

Just to be sure, are you using a recent version of the code?
We had issue with multiparticles in the past but none since quite a while.

Cheers,

Olivier

jackaraz (jackaraz) said : #2

Hi Oliver

Sorry forgot to mention its version = 2.6.4 date = 2018-11-09

Thanks
Jack

Hi Jack,

Coming back to this issue.
I would actually need more details in order to be able to reproduce this.
When I do
>import model SUSYQCD_UFO
> generate p p > go go [QCD]; output;launch -f
It crashes with "no pole cancelation"

if I tried inside that model
> define sq = b1 b1~ b2 b2~ dl dl~ dr dr~ sl sl~ sr sr~ ul ul~ cl cl~
it crashes with
InvalidCmd : No particle b1 in model

I also tried with
>import model SUSYQCD_UFO --modelname
but in that case as well they are no particle b1 in the model ...

So I'm not able to reproduce your behaviour without more information.

This being said,
I do not see the point to add the line
decay sq > j n1
Since you do not have ANY squark to decay in your event files (so this line just slow down the code for nothing)
maybe the line that you are looking for is:
decay go > sq j , sq > j n1

Cheers,

Olivier

Can you help with this problem?

Provide an answer of your own, or ask jackaraz for more information if necessary.

To post a message you must log in.