Problems with 'zi' in EPSFI subroutine in MadDipole

Asked by Biswajit Das on 2018-11-20

Hello,

I am trying to compute the dipole terms to a EW process in MadDipole. For QCD radiation, during the make in the folder SubProcesses/P1_udx_bbxw+g/ I get error with the declaration of 'zi' in EPSFI subroutine call in intdipoles.f file. One can succeed the error by defining the 'zi' as real in INTDIPOLES subroutine or can remove the 'zi'es from different calls. The output files(./check) for two cases are same. But, for the EW radiation 'zi' terms are significant in different calls. What is the use of 'zi ' for QCD radiation as well as for EW radiation.

Regards,
Biswajit

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
Rikkert Frederix Edit question
Last query:
2018-11-21
Last reply:
2018-11-21
Rikkert Frederix (frederix) said : #1

Dear Biswajit,

I can't reproduce your problem related to the declaration of 'zi'.

Which version of MadDipole are you using? What is the exact input you give? What is the process you give in the proc_card? Any other information that could be relevant?

Best,
Rikkert

Biswajit Das (bisubangla92) said : #2

Dear Rikkert,

I am using MadDipole version MG_ME_DIP_V4.5.1. I only edit in process card. In the process card I define process as

pp>bb~W+g @1 # First Process
QCD=99 # Max QCD couplings
QED=2 # Max QED couplings
end_coup # End the couplings input

pp>bb~W+a @2 # First Process
QCD=99 # Max QCD couplings
QED=2 # Max QED couplings
end_coup # End the couplings input

Here my process is pp>bb~W+ and I wish to compute the gluon radiation as well as photon radiation contribution to this process.

Thanks,
Biswajit

Rikkert Frederix (frederix) said : #3

Dear Biswajit,

You cannot combine the two processes in this way. You'll have to do the two independently -- they are generated by different scripts. See also here https://cp3.irmp.ucl.ac.be/projects/madgraph/wiki/MadDipole

Best,
Rikkert

Biswajit Das (bisubangla92) said : #4

Dear Rikkert,

I have generated the process separately as well(lets say for first process). But , the problems are still there. Please let me know about the functionality of 'zi' argument in 'EPSFI' subroutine call in intdipoles.f file for both process separately.

Thanking you,
Biswajit

Rikkert Frederix (frederix) said : #5

Dear Biswajit,

There is no 'zi' parameter anywhere when you do QCD corrections. Did you follow the instructions here https://cp3.irmp.ucl.ac.be/projects/madgraph/wiki/MadDipole ?

The appearance of 'zi' in the QED dipoles is explained in arXiv:1011.0321. It is related to a possible photon fragmentation function.

best,
Rikkert

Can you help with this problem?

Provide an answer of your own, or ask Biswajit Das for more information if necessary.

To post a message you must log in.