mad graph reweighs

Asked by David Axen on 2018-07-24

 greetings

  Previously I found a graphical user interface in which I was able to
  choose

    install CutTools
    install irreg.
    install ninja
    install collier

    now I am only able to install ninja and collier with ./bin/mg5_aMC followed by install ninja etc

  with these two installed when I try to reweight events with the following commands in the
  reweight_card.dat

  launch --rwgt_name=cwww0_cw20
   set EWdim_UFO 1 0
   set EWdim_UFO 2 20
   set EWdim_UFO 3 0
   set EWdim_UFO 4 0
   set EWdim_UFO 5 0
launch --rwgt_name=opt2
   set EWdim_UFO 1 20
   set EWdim_UFO 2 40
   set EWdim_UFO 3 0
   set EWdim_UFO 4 0
   set EWdim_UFO 5 0
launch --rwgt_name=opt3
   set EWdim_UFO 1 0
   set EWdim_UFO 2 0
   set EWdim_UFO 3 0
   set EWdim_UFO 4 0
   set EWdim_UFO 5 0

I get the following error

Command "generate_events " interrupted with error:
ValueError : need more than 1 value to unpack
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in '/home/axen/MG5_aMC_v2_6_3_2/Run_WZT/run_01_tag_1_debug.log'.
Please attach this file to your report.

  I thank you in advance for any help you can give me

     With kind regards

         David Axen

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
2018-07-24
Last query:
2018-07-24
Last reply:
2018-07-24

Hi,

Thanks for the report,
My guess is that such bug is actually a duplicated and therefore already fixed in the development version.
you can find here the associated patch:
https://bazaar.launchpad.net/~mg5core1/mg5amcnlo/2.6.4/revision/287
(you only need to patch the reweight_interface.py file for this bug)

Cheers,

Olivier

David Axen (davidaxen) said : #2

Thanks Olivier Mattelaer, that solved my question.