fortran error

Asked by Juan Carlos Vasquez Carmona on 2018-07-23

Dear Madgraph team,

I use MacOS 10.13.6. I recently install the latest version of MG5 v2_6_3_2.

As a test I generated the process p p > e+ e-. After I launch the process I got the following error:

Error detected in "generate_events run_01"
write debug file /Users/juancarlos/Documents/MG5_aMC_v2_6_3_2/PROC_sm_3/run_01_tag_1_debug.log
If you need help with this issue please contact us on https://answers.launchpad.net/mg5amcnlo
MadGraph5Error : A compilation Error occurs when trying to compile /Users/juancarlos/Documents/MG5_aMC_v2_6_3_2/PROC_sm_3/SubProcesses/P1_qq_ll.
 The compilation fails with the following output message:
     gfortran -O -w -fbounds-check -fPIC -ffixed-line-length-132 -w -c driver.f -I../../Source/
     gfortran -O -w -fbounds-check -fPIC -ffixed-line-length-132 -w -c myamp.f -I../../Source/
     gfortran -O -w -fbounds-check -fPIC -ffixed-line-length-132 -w -c genps.f -I../../Source/
     gfortran -O -w -fbounds-check -fPIC -ffixed-line-length-132 -w -c unwgt.f -I../../Source/
     genps.f:60:55:

            call gen_mom(iconfig,mincfig,maxcfig,invar,wgt,x,p)
                                                            1
     Error: Actual argument contains too few elements for dummy argument 'p1' (5/20) at (1)
     make: *** [genps.o] Error 1
     make: *** Waiting for unfinished jobs....

 Please try to fix this compilations issue and retry.
 Help might be found at https://answers.launchpad.net/mg5amcnlo.
 If you think that this is a bug, you can report this at https://bugs.launchpad.net/mg5amcnlo

I have the following gfortran version: GNU Fortran (Homebrew GCC 8.1.0) 8.1.0.

Any help on this issue would be very much appreciated.

Juan Carlos

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2018-07-23
Last reply:
2018-07-26

Hi Juan,

GCC8 breaks retro-compatibility and this breaks a lot of code including ours.
So for the moment we are not compatible with that version of GCC.

Cheers,

Olivier

Can you help with this problem?

Provide an answer of your own, or ask Juan Carlos Vasquez Carmona for more information if necessary.

To post a message you must log in.