using more than 4 coupling orders

Asked by alexandra carvalho on 2018-06-16

Dear developers

I am adding more loop structures and couplings on the model loop_sm
I am using VERSION 2.6.2

I would like to use it to generate interference-only processes.
To do that I need to add more than 4 types of couplings on coupling_orders.py
If I do so, I get the following error importing the model:

set group_subprocesses False
import model special_loop_sm
Traceback (most recent call last):
  File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/madgraph/interface/extended_cmd.py", line 1501, in onecmd
    return self.onecmd_orig(line, **opt)
  File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/madgraph/interface/extended_cmd.py", line 1450, in onecmd_orig
    return func(arg, **opt)
  File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/madgraph/interface/master_interface.py", line 274, in do_import
    self.cmd.do_import(self, *args, **opts)
  File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/madgraph/interface/madgraph_interface.py", line 5213, in do_import
    complex_mass_scheme=self.options['complex_mass_scheme'])
  File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/models/import_ufo.py", line 214, in import_model
    model = import_full_model(model_path, decay, prefix)
  File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/models/import_ufo.py", line 360, in import_full_model
    model = ufo2mg5_converter.load_model()
  File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/models/import_ufo.py", line 494, in load_model
    self.add_particle(particle_info)
  File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/models/import_ufo.py", line 705, in add_particle
    if key[i]==1:
IndexError: tuple index out of range

Is there a workaround to add more than 4 couplings types?

thank you
Xanda

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2018-06-19
Last reply:
2018-06-19

Hi,

We have many model with more than 4 coupling order.
So this is not the real problem of your model.

I actually seems to be an issue linked to some particle.

Cheers,

Olivier

> On 16 Jun 2018, at 16:43, alexandra carvalho <email address hidden> wrote:
>
> New question #670252 on MadGraph5_aMC@NLO:
> https://answers.launchpad.net/mg5amcnlo/+question/670252
>
> Dear developers
>
> I am adding more loop structures and couplings on the model loop_sm
> I am using VERSION 2.6.2
>
> I would like to use it to generate interference-only processes.
> To do that I need to add more than 4 types of couplings on coupling_orders.py
> If I do so, I get the following error importing the model:
>
>
> set group_subprocesses False
> import model special_loop_sm
> Traceback (most recent call last):
> File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/madgraph/interface/extended_cmd.py", line 1501, in onecmd
> return self.onecmd_orig(line, **opt)
> File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/madgraph/interface/extended_cmd.py", line 1450, in onecmd_orig
> return func(arg, **opt)
> File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/madgraph/interface/master_interface.py", line 274, in do_import
> self.cmd.do_import(self, *args, **opts)
> File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/madgraph/interface/madgraph_interface.py", line 5213, in do_import
> complex_mass_scheme=self.options['complex_mass_scheme'])
> File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/models/import_ufo.py", line 214, in import_model
> model = import_full_model(model_path, decay, prefix)
> File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/models/import_ufo.py", line 360, in import_full_model
> model = ufo2mg5_converter.load_model()
> File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/models/import_ufo.py", line 494, in load_model
> self.add_particle(particle_info)
> File "/afs/cern.ch/work/a/acarvalh/GridPacks/loop_MG_HH/MG5_aMC_v2_6_2/models/import_ufo.py", line 705, in add_particle
> if key[i]==1:
> IndexError: tuple index out of range
>
> Is there a workaround to add more than 4 couplings types?
>
> thank you
> Xanda
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

alexandra carvalho (acarvalh) said : #2

Hi Olivier

I did not add any particle on the model as it came from the default that is attached on this page
https://cp3.irmp.ucl.ac.be/projects/madgraph/wiki/LoopInducedTimesTree#no1

I did not even did the modifications on the MG files that Valentin add on this twiki yet.
This crash happens even if I just add more than 4 coupling order types, and disappear if I remove them

cheers
Xanda

Hi,

I have look more exactly to the code, and the problem is indeed related to the step of defining the particles.
But the problem is not directly linked to the particle itself but to the associate counter-term which are linked
to it.

Not sure what I can do more for you.
I can try to add N more coupling order within the loop_sm model, but i doubt that I will reproduce your issue like that.

Cheers,

Olivier

> On 19 Jun 2018, at 15:16, alexandra carvalho <email address hidden> wrote:
>
> Question #670252 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/670252
>
> Status: Answered => Open
>
> alexandra carvalho is still having a problem:
> Hi Olivier
>
> I did not add any particle on the model as it came from the default that is attached on this page
> https://cp3.irmp.ucl.ac.be/projects/madgraph/wiki/LoopInducedTimesTree#no1
>
> I did not even did the modifications on the MG files that Valentin add on this twiki yet.
> This crash happens even if I just add more than 4 coupling order types, and disappear if I remove them
>
> cheers
> Xanda
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

alexandra carvalho (acarvalh) said : #4

Hi Olivier

>I can try to add N more coupling order within the loop_sm model, but I doubt that I will reproduce your issue like that.

I do reproduce the problem with the loop_sm model.
I would need 6 additional coupling orders to make the model clear to the user.
But it is not fair to ask you to do something.

If it is possible to do it without changing internal MG files and you can give me some guidance I would appreciate.
Otherwise, I can make the model less clear using QCD and QED orders also for BSM and playing with using same order in different levels to two different BSM structures.

thank you
Xanda

Can you help with this problem?

Provide an answer of your own, or ask alexandra carvalho for more information if necessary.

To post a message you must log in.