No amplitudes generated from process p p > lq lq~ (using the leptoquark model)

Asked by Joydeep Roy on 2018-04-02

Hello,

I want to produce the leptoqurk and also to decay it, but there is some error in its generation:

MG5_aMC>generate p p > ltqk ltqk~
INFO: Checking for minimal orders which gives processes.
INFO: Please specify coupling orders to bypass this step.
INFO: Trying coupling order WEIGHTED<=2: WEIGTHED IS NP+2*QED+QCD
INFO: Trying coupling order WEIGHTED<=3: WEIGTHED IS NP+2*QED+QCD
INFO: Trying process: g g > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
INFO: Trying process: u u~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
INFO: Trying process: u c~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
INFO: Trying process: c u~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
INFO: Trying process: c c~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
INFO: Trying process: d d~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
INFO: Trying process: d s~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
INFO: Trying process: s d~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
INFO: Trying process: s s~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
Command "generate p p > ltqk ltqk~" interrupted with error:
NoDiagramException : No amplitudes generated from process Process: g/u/c/d/s/u~/c~/d~/s~ g/u/c/d/s/u~/c~/d~/s~ > ltqk ltqk~ NP=1 WEIGHTED=4 @1. Please enter a valid process

Why is this not a valid process ? Please help.

Thanks,
Joydeep

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2018-04-02
Last reply:
2018-04-02

Hi,

I'm not the author of the model and therefore I can not really comment why this is forbidden by your model.

Note that according to your log, your model force that you have at most one NP coupling in any Fenman diagram
If your model requires two NP coupling, then those diagram will not exists since this is forbidden by the model.

Cheers,

Olivier

> On 2 Apr 2018, at 07:52, Joydeep Roy <email address hidden> wrote:
>
> New question #667458 on MadGraph5_aMC@NLO:
> https://answers.launchpad.net/mg5amcnlo/+question/667458
>
> Hello,
>
> I want to produce the leptoqurk and also to decay it, but there is some error in its generation:
>
> MG5_aMC>generate p p > ltqk ltqk~
> INFO: Checking for minimal orders which gives processes.
> INFO: Please specify coupling orders to bypass this step.
> INFO: Trying coupling order WEIGHTED<=2: WEIGTHED IS NP+2*QED+QCD
> INFO: Trying coupling order WEIGHTED<=3: WEIGTHED IS NP+2*QED+QCD
> INFO: Trying process: g g > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
> INFO: Trying process: u u~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
> INFO: Trying process: u c~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
> INFO: Trying process: c u~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
> INFO: Trying process: c c~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
> INFO: Trying process: d d~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
> INFO: Trying process: d s~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
> INFO: Trying process: s d~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
> INFO: Trying process: s s~ > ltqk ltqk~ NP<=1 WEIGHTED<=4 @1
> Command "generate p p > ltqk ltqk~" interrupted with error:
> NoDiagramException : No amplitudes generated from process Process: g/u/c/d/s/u~/c~/d~/s~ g/u/c/d/s/u~/c~/d~/s~ > ltqk ltqk~ NP=1 WEIGHTED=4 @1. Please enter a valid process
>
> Why is this not a valid process ? Please help.
>
> Thanks,
> Joydeep
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Joydeep Roy (madubu17) said : #2

I'm trying to write the model by myself and following your suggestion I tried to increase the NP coupling to 2, but still no luck !

Regards,
Joydeep

Hi,

This limit is hardcoded in the model. (i.e. it is coming from FR).
So if you do
generate p p > ltqk ltqk~ NP<=2
MG5aMC will not allow it since the mode specify that such syntax is not valid.

If you want to allow such syntax for your model, you need to change the fr file (do not ask me how)
or the UFO file.
This information is strore in couplings_order.py (the flag to change is perturbation_order)

Cheers,

Olivier

> On 2 Apr 2018, at 11:13, Joydeep Roy <email address hidden> wrote:
>
> Question #667458 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/667458
>
> Joydeep Roy posted a new comment:
> I'm trying to write the model by myself and following your suggestion I
> tried to increase the NP coupling to 2, but still no luck !
>
> Regards,
> Joydeep
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Joydeep Roy (madubu17) said : #4

Okay, now I'm able to generate the process p p > ltqk ltqk~, but while trying to decay it there is the error message about what I asked a question previously. The message is the following :
.
.
.
.
NFO: Process u~ u > ltqk ltqk~ added to mirror process u u~ > ltqk ltqk~
INFO: Process c~ c > ltqk ltqk~ added to mirror process c c~ > ltqk ltqk~
INFO: Process d~ d > ltqk ltqk~ added to mirror process d d~ > ltqk ltqk~
INFO: Process s~ s > ltqk ltqk~ added to mirror process s s~ > ltqk ltqk~
INFO: Checking for minimal orders which gives processes.
INFO: Please specify coupling orders to bypass this step.
Command "generate p p > ltqk ltqk~, ltqk~ > t mu-, t > w+ b" interrupted with error:
InvalidCmd : The number of of incoming/outcoming fermions are different

I'm already using coupling order 2 for NP following your suggestion.

For your convenience I'm providing the 'coupling_orders.py' file generated during the creation of UFO file.

This file was automatically created by FeynRules 2.3.29
# Mathematica version: 11.1.0 for Microsoft Windows (64-bit) (March 13, 2017)
# Date: Mon 2 Apr 2018 13:09:49

from object_library import all_orders, CouplingOrder

NP = CouplingOrder(name = 'NP',
                   expansion_order = 3,
                   hierarchy = 2)

QCD = CouplingOrder(name = 'QCD',
                    expansion_order = 99,
                    hierarchy = 1)

QED = CouplingOrder(name = 'QED',
                    expansion_order = 99,
                    hierarchy = 2)

Joydeep

Hi,

1) the correct syntax should be
> generate p p > ltqk ltqk~, (ltqk~ > t mu-, t > w+ b)
Since the "t" is a sub-decay and not a decay of the main process.

2) ltqk~ > t mu- is not valid and this is why MG5aMC is complaining about.

Both the "t" and the "mu-" are incoming fermion and therefore you need
to have a fermion-flow violation vertex to have such kind of diagram.
MG5aMC did not spot any of such type of vertex in your model.

So are you sure that you have such vertex in your model?

Cheers,

Olivier

> On 2 Apr 2018, at 11:42, Joydeep Roy <email address hidden> wrote:
>
> Question #667458 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/667458
>
> Status: Answered => Open
>
> Joydeep Roy is still having a problem:
> Okay, now I'm able to generate the process p p > ltqk ltqk~, but while trying to decay it there is the error message about what I asked a question previously. The message is the following :
> .
> .
> .
> .
> NFO: Process u~ u > ltqk ltqk~ added to mirror process u u~ > ltqk ltqk~
> INFO: Process c~ c > ltqk ltqk~ added to mirror process c c~ > ltqk ltqk~
> INFO: Process d~ d > ltqk ltqk~ added to mirror process d d~ > ltqk ltqk~
> INFO: Process s~ s > ltqk ltqk~ added to mirror process s s~ > ltqk ltqk~
> INFO: Checking for minimal orders which gives processes.
> INFO: Please specify coupling orders to bypass this step.
> Command "generate p p > ltqk ltqk~, ltqk~ > t mu-, t > w+ b" interrupted with error:
> InvalidCmd : The number of of incoming/outcoming fermions are different
>
>
> I'm already using coupling order 2 for NP following your suggestion.
>
> For your convenience I'm providing the 'coupling_orders.py' file
> generated during the creation of UFO file.
>
>
> This file was automatically created by FeynRules 2.3.29
> # Mathematica version: 11.1.0 for Microsoft Windows (64-bit) (March 13, 2017)
> # Date: Mon 2 Apr 2018 13:09:49
>
>
> from object_library import all_orders, CouplingOrder
>
>
> NP = CouplingOrder(name = 'NP',
> expansion_order = 3,
> hierarchy = 2)
>
> QCD = CouplingOrder(name = 'QCD',
> expansion_order = 99,
> hierarchy = 1)
>
> QED = CouplingOrder(name = 'QED',
> expansion_order = 99,
> hierarchy = 2)
>
>
> Joydeep
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Joydeep Roy (madubu17) said : #6

Hi Olivier,

1) Yes, I knew about the correct syntax, just forgot to implement. Thanks for the correction.

2) I used ltqk~ because last time there was the same issue of incoming/outgoing fermion-flow and I asked the question in the forum and you suggested to try ' ltqk~ > t mu- ', but that is not very important.

The important thing is the question you have asked about the fermion-flow violation vertex. That I need to verify, whether that exists in our model ! Thanks for the explanation.

Regards,
Joydeep

Can you help with this problem?

Provide an answer of your own, or ask Joydeep Roy for more information if necessary.

To post a message you must log in.