Invalid event format in Delphes when varying qcut

Asked by Joel Jones on 2018-03-13

I am running the MadGraph + Pythia8 + Delphes chain, and I am getting a problem similar to this one: https://cp3.irmp.ucl.ac.be/projects/delphes/ticket/1078

I have installed the latest versions of MadGraph, hepmc, Delphes and ExRootAnalysis. I am running on a Fedora system, with a global root installation (this also happens for a locally installed root v6.12.06).

The strange thing is that this problem happens for specific values of qcut. The process I am looking at is p p > nu nu~ + Jets (up to four), with xqcut = 10 GeV. If I set qcut = 15 GeV, there is no problem, and Delphes runs normally. If I change qcut = 20 GeV or 30 GeV, then I get an "** ERROR: invalid event format" on the Delphes log.

No idea how to proceed. Could I get any help?

Question information

Language:
English Edit question
Status:
Needs information
For:
MadGraph5_aMC@NLO Edit question
Assignee:
Olivier Mattelaer Edit question
Last query:
2018-03-19
Last reply:
2018-04-05
Joel Jones (n-jones-j) said : #1

Hi, the issue was eventually solved here: https://cp3.irmp.ucl.ac.be/projects/delphes/ticket/1299#no4

It was related to the systematics. Once I run off systematics, I call generate_events and everything works smoothly.

A different problem appears later, though. If I call madevent, and then just run pythia8 run_XX, I get a new error:

Merging results from the split PY8 runs...
INFO: Create matching plots for Pythia8
Command "pythia8 run_06" interrupted with error:
KeyError : 'mgruncard'
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in '/home/jjones/Programs/MG5_aMC_v2_6_0/ppNuNu2/run_06_tag_3_debug.log'.
Please attach this file to your report.

The Pythia hepmc event file is created without a problem, though, and I can use it with Delphes later.

Can you include the relevant part of the error log file?

/home/jjones/Programs/MG5_aMC_v2_6_0/ppNuNu2/run_06_tag_3_debug.log

Can you help with this problem?

Provide an answer of your own, or ask Joel Jones for more information if necessary.

To post a message you must log in.