KeyError : ((2, 5), (1, 2, 23))

Asked by SUBHASISH BEHERA on 2018-03-06

Dear Oliver,

I am using : MG5_aMC_v2_6_1
I have the following issue while launch an event with an UFO file which is "SM + ztq(u,c)" file.

INFO: Estimating the maximum weight
INFO: *****************************
INFO: Probing the first 75 events
INFO: with 400 phase space points
Command "generate_events run_01" interrupted with error:
KeyError : ((2, 5), (1, 2, 23))
Please report this bug on
More information is found in '/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/pp2tj2zj/run_01_tag_1_debug.log'.
Please attach this file to your report.
INFO: storing files of previous run
The debug file is :

generate_events run_01
Traceback (most recent call last):
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/interface/", line 1467, in onecmd
    return self.onecmd_orig(line, **opt)
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/interface/", line 1421, in onecmd_orig
    return func(arg, **opt)
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/interface/", line 2551, in do_generate_events
    self.exec_cmd('decay_events -from_cards', postcmd=False)
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/interface/", line 1494, in exec_cmd
    stop = Cmd.onecmd_orig(current_interface, line, **opt)
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/interface/", line 1421, in onecmd_orig
    return func(arg, **opt)
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/interface/", line 3477, in do_decay_events
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/interface/", line 1609, in import_command_file
    self.exec_cmd(line, precmd=True)
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/interface/", line 1494, in exec_cmd
    stop = Cmd.onecmd_orig(current_interface, line, **opt)
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/interface/", line 1421, in onecmd_orig
    return func(arg, **opt)
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/madgraph/various/", line 100, in f_with_no_logger
    out = f(self, *args, **opt)
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/MadSpin/", line 582, in do_launch
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/MadSpin/", line 2118, in run
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/MadSpin/", line 3073, in get_max_weight_from_event
    production_tag, event_map = self.load_event()
  File "/home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/MadSpin/", line 3212, in load_event
    P_order = self.all_ME[production_tag]['tag2order'][production_tag]
KeyError: ((2, 5), (1, 2, 23))
                              Run Options
               stdout_level : 20 (user set)

                         MadEvent Options
     automatic_html_opening : False (user set)
        notification_center : True
          cluster_temp_path : None
             cluster_memory : None (user set)
               cluster_size : 100
             cluster_queue : None (user set)
                    nb_core : 4 (user set)
               cluster_time : 4 (user set)
                   run_mode : 2

                      Configuration Options
                text_editor : None
         cluster_local_path : None
      cluster_status_update : (600, 30)
               pythia8_path : None (user set)
                  hwpp_path : None (user set)
            pythia-pgs_path : /home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/pythia-pgs (user set)
                    td_path : None (user set)
               delphes_path : /home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/Delphes (user set)
                thepeg_path : None (user set)
               cluster_type : condor
          madanalysis5_path : None (user set)
           cluster_nb_retry : 1
                 eps_viewer : None
                web_browser : None
               syscalc_path : None (user set)
           madanalysis_path : None (user set)
                     lhapdf : /home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/HEPTools/lhapdf5/bin/lhapdf-config (user set)
              f2py_compiler : None
                 hepmc_path : None (user set)
         cluster_retry_wait : 300
           fortran_compiler : None
                auto_update : 7 (user set)
        exrootanalysis_path : /home/subhasish152.local/RESEARCH/EVENT_GENERATORS/MADGRAPH5/MG5_aMC_v2_6_1/ExRootAnalysis (user set)
                    timeout : 60
               cpp_compiler : None
#* MadGraph5_aMC@NLO *
#* *

and so on...


Question information

English Edit question
MadGraph5_aMC@NLO Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

Sorry for posting this.
The issue with the UFO file as it don't have in it.



I do not see how this should be related to the UFO file.
Now they are a now bug for madspin in 2.6.1. I thought this was only for NLO process, but according to your bug report this seems to also occurs for LO one.



Dear Olivier,

You may be right. But once I corrected the model file by the following :

1. I write all the parameters and also the Lagrangian in the same files itself.
2. Change the Coupling_order hierarchy for NP=3.

Then I generated the model file. I have checked every files it has generated and all seems to be ok. Now it is working fine but another different problem I encounter while generating :

1. I tried the process :
define p = p b b~
generate p p > t j : this generate 4 process (SM only)
generate p p > t j /w+ w- : this generate 24 process (which are NP only)
generate p p > t j NP=1 : this generate 28 process (which are NP + SM together)
define p = j
generate p p > t j /w+ w- : this generate 22 process (which are NP only).

This is alright because in 4-flavour scheme it don't have any option and hence it generated the available process only but in 5-flavour scheme it ONLY takes the SM processes only. We have to specify NP in generating new physics process of the model otherwise it won't generate them directly, is it ?

I also had a small discussion with Deepanjali, and her problem was somehow related to specifying coupling orders etc..