installing ninja

Asked by Amin Aboubrahim on 2018-03-05

Hi MG5 team,

I am generating ttbar samples at NLO, (adding [QCD]) and in the process, MG5 wants to install ninja. I am getting this:

You are installing 'ninja', please cite ref(s): arXiv:1203.0291, arXiv:1403.1229, arXiv:1604.01363.
Downloading the HEPToolInstaller at:
   http://madgraph.physics.illinois.edu/Downloads/HEPToolsInstaller/HEPToolsInstaller_V99.tar.gz
Now installing ninja. Be patient...
Fetching data with command:
  wget --no-check-certificate https://bitbucket.org/peraro/ninja/downloads/ninja-latest.tar.gz
--2018-03-05 14:54:59-- https://bitbucket.org/peraro/ninja/downloads/ninja-latest.tar.gz
Resolving bitbucket.org... 104.192.143.2, 104.192.143.3, 104.192.143.1, ...
Connecting to bitbucket.org|104.192.143.2|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://bbuseruploads.s3.amazonaws.com/21678e19-7e54-4a85-867a-6501efba753d/downloads/4424e9c9-a51d-4505-89dd-08e4c2458f85/ninja-latest.tar.gz?Signature=1bzg9BIVkR%2B0gGTO%2FmOQ0A3RHjE%3D&Expires=1520281500&AWSAccessKeyId=AKIAIQWXW6WLXMB5QZAQ&versionId=aC2DjNeNwcxy11KQy7SnI2._rgfQJjCR&response-content-disposition=attachment%3B%20filename%3D%22ninja-latest.tar.gz%22 [following]
--2018-03-05 14:55:00-- https://bbuseruploads.s3.amazonaws.com/21678e19-7e54-4a85-867a-6501efba753d/downloads/4424e9c9-a51d-4505-89dd-08e4c2458f85/ninja-latest.tar.gz?Signature=1bzg9BIVkR%2B0gGTO%2FmOQ0A3RHjE%3D&Expires=1520281500&AWSAccessKeyId=AKIAIQWXW6WLXMB5QZAQ&versionId=aC2DjNeNwcxy11KQy7SnI2._rgfQJjCR&response-content-disposition=attachment%3B%20filename%3D%22ninja-latest.tar.gz%22
Resolving bbuseruploads.s3.amazonaws.com... 52.216.17.120
Connecting to bbuseruploads.s3.amazonaws.com|52.216.17.120|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 581743 (568K) [application/x-tar]
Saving to: “ninja-latest.tar.gz?Signature=1bzg9BIVkR+0gGTO%2FmOQ0A3RHjE=&Expires=1520281500&AWSAccessKeyId=AKIAIQWXW6WLXMB5QZAQ&versionId=aC2DjNeNwcxy11KQy7SnI2._rgfQJjCR&response-content-disposition=attachment; filename="ninja-latest.tar.gz"

100%[===============================================================================================================================================================>] 581,743 2.74M/s in 0.2s

2018-03-05 14:55:01 (2.74 MB/s) - “ninja-latest.tar.gz?Signature=1bzg9BIVkR+0gGTO%2FmOQ0A3RHjE=&Expires=1520281500&AWSAccessKeyId=AKIAIQWXW6WLXMB5QZAQ&versionId=aC2DjNeNwcxy11KQy7SnI2._rgfQJjCR&response-content-disposition=attachment; filename="ninja-latest.tar.gz"” saved [581743/581743]

Could not download data at '/tmp/tmp2FubIA/ninja-latest.tar.gz'.
Command "import /home/abouibrahim.a/MG5_aMC_v2_6_0/bin/loop_proc_card.dat" interrupted in sub-command:
"output tt_qcd" with error:
InvalidCmd : Installation of ninja failed.
quit

It seems that the tarball was downloaded but I'm not sure why it says "Could not download". I tried several times so I don't think it is a network issue. Any idea what's happening?

Thank you,
Amin

Question information

Language:
English Edit question
Status:
Needs information
For:
MadGraph5_aMC@NLO Edit question
Assignee:
Valentin Hirschi Edit question
Last query:
2018-03-07
Last reply:
2018-03-18
Amin Aboubrahim (amin83) said : #1

Hi Valentin,

I tried installing ninja from MG5 prompt by typing "install ninja" but still it fails.
Any suggestions?

Thank you,
Amin

Sorry for the late reply, it may have been an issue of your internet connection. Do you still have this problem?

Can you help with this problem?

Provide an answer of your own, or ask Amin Aboubrahim for more information if necessary.

To post a message you must log in.