How to install Pythia8 with MG5

Asked by guy pitman

I have looked at documentation and Launchpad but still am having problems getting Pythia8 to compile under MG5

I get the error Compiling MCatNLO for PYTHIA8...
/cvmfs/atlas.cern.ch/repo/ATLASLocalRootBase/x86_64/Gcc/gcc462_x86_64_slc6/slc6/x86_64-slc6-gcc46-opt/bin/../libexec/gcc/x86_64-unknown-linux-gnu/4.6.2/cc1plus: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /cvmfs/atlas.cern.ch/repo/ATLASLocalRootBase/x86_64/Gcc/gcc462_x86_64_slc6/slc6/gcc46/lib64/libppl_c.so.4)
/cvmfs/atlas.cern.ch/repo/ATLASLocalRootBase/x86_64/Gcc/gcc462_x86_64_slc6/slPythia8 compilation did not succeed, exiting
86_64-unknown-linux-gnu/4.6.2/cc1plus: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /cvmfs/atlas.cern.ch/repo/ATLASLocalRootBase/x86_64/Gcc/gcc462_x86_64_slc6/slc6/gcc46/lib64/libppl.so.9)
make: *** [Pythia82] Error 1

I have installed HepMC from source with gcc481 and also Pythia8 which is linked to HepMC via --with-hepmc2=[DIR]. I have edited the pythia8_path in mg5_configuration.txt. I cant see why it is looking for gcc462, and this is not available.

Can you suggest what I am doing wrong?

Many thanks

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
Paolo Torrielli Edit question
Solved by:
Paolo Torrielli
Solved:
Last query:
Last reply:
Revision history for this message
Paolo Torrielli (paolo-torrielli) said :
#1

Dear Guy,
thanks very much for your feedback.
Your problem seems to be due to a compiler clash, in turn probably caused by our
Pythia8 makefiles that incorrectly set the compilers without any reference to the
the configuration file.

Could you please try and modify the two files MCatNLO/srcPythia8/Makefile and
MCatNLO/srcPythia8/Makefile_hep, so that their first lines look like below?

SHELL = /bin/sh

-include $(PYTHIA8LOCATION)/config.mk
-include ../Source/make_opts

F77=$(FC)
DEBUG=
FF=$(F77) $(DEBUG)

# Location of directories.
TOPDIR=$(shell \pwd)
INCDIR=include
SRCDIR=src
LIBDIR=lib
LIBDIRARCH=lib/archive
....
....

Let me know if this works. If it does, I'll immediately change these files for
our next release.
Thanks again.
Cheers.
Paolo

Revision history for this message
guy pitman (guy-pitman) said :
#2

Hi Paolo,

I tried this -I edited the Makefiles in Template/NLO/MCatNLO/etc , removed the lines up to
# Libraries to include if GZIP support is enabled
and replaced with the lines you gave , but I still get the same error?

Revision history for this message
Paolo Torrielli (paolo-torrielli) said :
#3

Hi Guy,

changes in the Template folder do not affect the already-generated
processes. You should edit these makefiles in the folder
<proc_name>/MCatNLO/srcPythia8, where <proc_name> is the name you
gave at the process folder where you generated the events.

Anyway, if the suggested editing does not work, you could try and
set F77 = <path_to_fortran_compiler> by hand in the makefiles.

Let me know.
Cheers.
Paolo

On 21 Oct 2015, at 00:08, guy pitman <email address hidden> wrote:

> Question #272632 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/272632
>
> Status: Answered => Open
>
> guy pitman is still having a problem:
> Hi Paolo,
>
> I tried this -I edited the Makefiles in Template/NLO/MCatNLO/etc , removed the lines up to
> # Libraries to include if GZIP support is enabled
> and replaced with the lines you gave , but I still get the same error?
>
> --
> You received this question notification because you are subscribed to
> the question.

Revision history for this message
guy pitman (guy-pitman) said :
#4

Hi Paolo,

I tried editing those files and the ran ./bin/aMCatNLO and shower run_01

I still get the same error.

I dont know how to find the path to fortran as it is automatically set up by setupATLAS command on our coepp machine?

Regards

Guy

Revision history for this message
Best Paolo Torrielli (paolo-torrielli) said :
#5

Dear Guy,

for the fortran version you could try ‘which gfortran’ or ‘gfortran --version'.

However, the problem seems to be rather that you are running with gcc462 (which
probably is the default on your machine), while installed HepMC/Pythia8 with
gcc481.

Could you try and run with gcc481 (by setting the 481 compilers (gfortran in
particular) in input/mg5_configuration.txt and making sure our Pythia8 makefiles
read this information)?

Cheers,
Paolo

On 21 Oct 2015, at 14:17, guy pitman <email address hidden> wrote:

> Question #272632 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/272632
>
> Status: Answered => Open
>
> guy pitman is still having a problem:
> Hi Paolo,
>
> I tried editing those files and the ran ./bin/aMCatNLO and shower run_01
>
> I still get the same error.
>
> I dont know how to find the path to fortran as it is automatically set
> up by setupATLAS command on our coepp machine?
>
> Regards
>
> Guy
>
> --
> You received this question notification because you are subscribed to
> the question.

Revision history for this message
guy pitman (guy-pitman) said :
#6

Thanks Paolo Torrielli, that solved my question.