How can I increase the precision

Asked by alireza.daneshvar

Hello all,

I am trying to calculate the NLO cross-section for this process, p p > a c, with the obtion fixed_order=on.
but in each run I got different value for cross section it vary between 10 to 11.5.
For high precision calculation is there any way to fix the output, or not?
How can I improve the precision of calculation to reduce the variation?

Thanks,
Alireza.

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
marco zaro Edit question
Solved by:
alireza.daneshvar
Solved:
Last query:
Last reply:
Revision history for this message
marco zaro (marco-zaro) said :
#1

Hi,
in the run_card you have these entries for the FO runs
 0.01 = req_acc_FO ! Required accuracy (-1=ignored, and use the
                           ! number of points and iter. below)
# These numbers are ignored except if req_acc_FO is equal to -1
 5000 = npoints_FO_grid ! number of points to setup grids
 4 = niters_FO_grid ! number of iter. to setup grids
 10000 = npoints_FO ! number of points to compute Xsec
 6 = niters_FO ! number of iter. to compute Xsec

so the simplest thing is to reduce req_acc_FO, which is the nominal accuracy on the final cross-section.
alternatively you can also think of increasing the number of points thrown at Xsection computation, but the accuracy setting should be easier.

I am worried about the process you are generating.
Are you using massive or massless charms?
if the charm is massless, then your process is ill defined as some real emissions, such as c u > a c u can have singularities corresponding to other processes, eg. c g > a c (the gluon in the initial state splits collinearly in a u u~ pair)

Let me know,

Marco

Revision history for this message
alireza.daneshvar (alireza-daneshvar) said :
#2

Hi Marco,
Thank you for your consideration, you are very helpful.
Thanks
Alireza.

Revision history for this message
shibasipu (shibasipu) said :
#3

Hello Alireza,

                        I am also facing similar problem. For one particular set of parameters, the crosssection of a process returns the value 281.7 fb. But in the literature it is given as 289.2 fb. I think it is a matter of precision. But I do not know how to use the "fixed_order=on " option ? Could you please tell the syntax ?

Regards,
Shiba

Revision history for this message
marco zaro (marco-zaro) said :
#4

Dear Alireza, Shiba,
first of all, again, are you using the model with the charm mass?
Then, these processes, with a "light" massive quark (b or c) have a large fraction of negative weights. What happens is that the integral of the abs of the cross-section is much larger than the cross-section itself. Since (if i am not completely wrong) the precision is usually computed with respect to the abs of the xsect, this may explain why you get such fluctuations.
Can you please check the res*.txt files in the Events/run... folders? The last two lines are the abs and the cross-section...

Let me know,

Cheers,

Marco

Revision history for this message
alireza.daneshvar (alireza-daneshvar) said :
#5

Hello Shimba,

If you want to use fixed_order option do the following inctruction:
launch your process
doing so we get the following message:

The following switches determine which operations are executed:
 1 Perturbative order of the calculation: order=NLO
 2 Fixed order (no event generation and no MC@[N]LO matching): fixed_order=OFF
 3 Shower the generated events: shower=ON
 4 Decay particles with the MadSpin module: madspin=OFF
  Either type the switch number (1 to 4) to change its default setting,
  or set any switch explicitly (e.g. type 'order=LO' at the prompt)
  Type '0', 'auto', 'done' or just press enter when you are done.
 [0, 1, 2, 3, 4, auto, done, order=LO, order=NLO, ... ][60s to answer]

This means that by default the code would run in the NLO+PS mode. but
in the fixed-order mode therefore we need to
deactivate the parton shower and this is easily done by typing *2*.
This way we get the message:

 INFO: For coherence 'shower' is set to 'OFF'
The following switches determine which operations are executed:
 1 Perturbative order of the calculation: order=NLO
 2 Fixed order (no event generation and no MC@[N]LO matching): fixed_order=ON
 3 Shower the generated events: shower=OFF
 4 Decay particles with the MadSpin module: madspin=OFF
  Either type the switch number (1 to 4) to change its default setting,
  or set any switch explicitly (e.g. type 'order=LO' at the prompt)
  Type '0', 'auto', 'done' or just press enter when you are done.
 [0, 1, 2, 3, 4, auto, done, order=LO, order=NLO, ... ][60s to answer]

moreover, if you want to increase the accuracy you can reduce the
following parameter in the run card
0.01 = req_acc_FO
 for example put it 0.001.

Best,

Alireza.

On Tue, Apr 28, 2015 at 11:46 AM, shibasipu <
<email address hidden>> wrote:

> Your question #258290 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/258290
>
> shibasipu posted a new comment:
> Hello Alireza,
>
> I am also facing similar problem. For one
> particular set of parameters, the crosssection of a process returns the
> value 281.7 fb. But in the literature it is given as 289.2 fb. I think
> it is a matter of precision. But I do not know how to use the
> "fixed_order=on " option ? Could you please tell the syntax ?
>
>
> Regards,
> Shiba
>
> --
> You received this question notification because you asked the question.
>

Revision history for this message
alireza.daneshvar (alireza-daneshvar) said :
#6

Hello Shimba,

If you want to use fixed_order option do the following inctruction:
launch your process
doing so we get the following message:

The following switches determine which operations are executed:
 1 Perturbative order of the calculation: order=NLO
 2 Fixed order (no event generation and no MC@[N]LO matching): fixed_order=OFF
 3 Shower the generated events: shower=ON
 4 Decay particles with the MadSpin module: madspin=OFF
  Either type the switch number (1 to 4) to change its default setting,
  or set any switch explicitly (e.g. type 'order=LO' at the prompt)
  Type '0', 'auto', 'done' or just press enter when you are done.
 [0, 1, 2, 3, 4, auto, done, order=LO, order=NLO, ... ][60s to answer]

This means that by default the code would run in the NLO+PS mode. but
in the fixed-order mode therefore we need to
deactivate the parton shower and this is easily done by typing *2*.
This way we get the message:

 INFO: For coherence 'shower' is set to 'OFF'
The following switches determine which operations are executed:
 1 Perturbative order of the calculation: order=NLO
 2 Fixed order (no event generation and no MC@[N]LO matching): fixed_order=ON
 3 Shower the generated events: shower=OFF
 4 Decay particles with the MadSpin module: madspin=OFF
  Either type the switch number (1 to 4) to change its default setting,
  or set any switch explicitly (e.g. type 'order=LO' at the prompt)
  Type '0', 'auto', 'done' or just press enter when you are done.
 [0, 1, 2, 3, 4, auto, done, order=LO, order=NLO, ... ][60s to answer]

moreover, if you want to increase the accuracy you can reduce the
following parameter in the run card

0.01 = req_acc_FO
for example put it 0.001

On Tue, Apr 28, 2015 at 11:46 AM, shibasipu <
<email address hidden>> wrote:

> Your question #258290 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/258290
>
> shibasipu posted a new comment:
> Hello Alireza,
>
> I am also facing similar problem. For one
> particular set of parameters, the crosssection of a process returns the
> value 281.7 fb. But in the literature it is given as 289.2 fb. I think
> it is a matter of precision. But I do not know how to use the
> "fixed_order=on " option ? Could you please tell the syntax ?
>
>
> Regards,
> Shiba
>
> --
> You received this question notification because you asked the question.
>