Problem with Delphes FastJetFinder

Asked by Kerry Parker on 2014-02-04

Hi,

I have a problem when running Delphes. I have used the 'install Delphes' command and when I execute Delphes using './Delphes/DelphesSTDHEP TEST1/Cards/delphes_card_ATLAS.tcl DELPHES_OUTPUT2.root TEST1/Events/run_01/
tag_1_pythia_events.hep' (after having unzipped the pythia file).

I get the following error:

** ERROR: parameter 'FastJetFinder::AdjacencyCut' is not an integer.
FastJetFinder::AdjacencyCut = 2.0

I'm not sure how to fix this problem, please could you let me know what I need to do.

Many thanks

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2014-02-04
Last reply:
2014-02-06

Hi,

I've created a ticket for this on the Delphes ticket system:
https://cp3.irmp.ucl.ac.be/projects/delphes/ticket/250

Cheers,

Olivier

Pavel Demin (pavel-demin) said : #2

The AdjacencyCut parameter should be integer. In the Delphes configuration file it should look like

set AdjacencyCut 2

Is it possible that the templates of Delphes configuration files provided by MadGraph are not synchronized with the latest Delphes version?

Hi Pavel,

MadGraph automatically copy the card: delphes_card_CMS.tcl
to the Template directory:
(here is the line doing so)
        if args[0] == 'Delphes3':
            files.cp(pjoin(MG5DIR, 'Delphes','examples','delphes_card_CMS.tcl'),
                     pjoin(MG5DIR,'Template', 'Common', 'Cards', 'delphes_card_default.dat'))

Now, this instance of Delphes is not called via MadGraph. So I have no idea which file is used for the configuration.

Cheers,

Olivier

On Feb 4, 2014, at 10:51 AM, Pavel Demin <email address hidden> wrote:

> Question #243254 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/madgraph5/+question/243254
>
> Pavel Demin proposed the following answer:
> The AdjacencyCut parameter should be integer. In the Delphes
> configuration file it should look like
>
> set AdjacencyCut 2
>
> Is it possible that the templates of Delphes configuration files
> provided by MadGraph are not synchronized with the latest Delphes
> version?
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Markus Ebert (markus-ebert) said : #4

Hi Olivier,

I am sorry to disagree with you, but it seems that the copying does not work.
I just tested it by reinstalling MG (1.5.13) and Delphes.
At least for me, the Delphes-cards that are included in MadGraph are NOT replaced when installing Delphes,
except for delphes_card_default.dat which is replaced by Delphes/examples/delphes_card_CMS.tcl.

Cheers,
Markus

Hi Markus,

> I am sorry to disagree with you, but it seems that the copying does not work.
> I just tested it by reinstalling MG (1.5.13) and Delphes.
> At least for me, the Delphes-cards that are included in MadGraph are NOT replaced when installing Delphes,
> except for delphes_card_default.dat which is replaced by Delphes/examples/delphes_card_CMS.tcl.

This is indeed the only file which is automatically modified and to my knowledge the only used by the madgraph/madevent interface when Delphes3 is installed.
Now indeed they are the file delphes_card_ATLAS.dat and delphes_card_CMS.dat which are in the Delphes2 format and which are not removed.
Is that your point?

Which file did you use for your run?

Cheers,

Olivier

On Feb 6, 2014, at 5:35 PM, Markus Ebert <email address hidden> wrote:

> Question #243254 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/madgraph5/+question/243254
>
> Markus Ebert posted a new comment:
> Hi Olivier,
>
> I am sorry to disagree with you, but it seems that the copying does not work.
> I just tested it by reinstalling MG (1.5.13) and Delphes.
> At least for me, the Delphes-cards that are included in MadGraph are NOT replaced when installing Delphes,
> except for delphes_card_default.dat which is replaced by Delphes/examples/delphes_card_CMS.tcl.
>
>
> Cheers,
> Markus
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Markus Ebert (markus-ebert) said : #6

Hi Olivier,

I think the problem is that it looks like one could use the ATLAS and CMS files shipped with MadGraph for detector simulation, if you replace delphes_card.dat with them.
However, one should use the files provided by delphes, as the ATLAS file is not working, so I would recommend to copy also the ATLAS/CMS detector cards from delphes, just to avoid confusion.

Cheers,
Markus

Can you help with this problem?

Provide an answer of your own, or ask Kerry Parker for more information if necessary.

To post a message you must log in.