lhapdf with MadGraph v1.4.2

Asked by Busato on 2012-03-12

Dear MadGraph team,

I'm working with MadGraph v1.4.2 and I'd like to use the MSTW2008lo68cl pdf rather than the default CTEQ6l1. From what I understood I need to use lhapdf to do that. Following the instructions in README.lhapdf, I did:

 1. download and compile LHAPDF
 2. copy libLHAPDF.a, in my Template/lib directory
 3. create Template/lib/PDFsets/ and copy MSTW2008lo68cl.LHgrid in it (I downloaded this file from http://lhapdf.hepforge.org/pdfsets)
 4. put in my run_card.dat the following:
        'lhapdf' = pdlabel ! PDF set
        21000 = lhaid ! PDF number used ONLY for LHAPDF
 5. run using: bin/generate_events 0 test

When doing this it runs without errors. However, it also runs without errors when pdlabel and lhaid are set to values that make no sense. For example, it runs fine when I put:

     'toto' = pdlabel ! PDF set
      21000 = lhaid ! PDF number used ONLY for LHAPDF

or

    'lhapdf' = pdlabel ! PDF set
    12345 = lhaid ! PDF number used ONLY for LHAPDF

It even runs fine when I comment the line specifying the lhaid :

     'lhapdf' = pdlabel ! PDF set
   # 12345 = lhaid ! PDF number used ONLY for LHAPDF

So my changes in run_card.dat don't seem to be taken into account by MadGraph, which apparently uses a default pdf when the specified one does not exist.

Would anyone have an idea of what I'm doing wrong ? And is there anything to do in particular to be sure that MadGraph uses the right pdf ?

Thanks in advance,
Emmanuel

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Johan Alwall
Solved:
2012-03-15
Last query:
2012-03-15
Last reply:
2012-03-15

Hi Emmanuel,

Indeed if you put crazy parameter, MG will reject those and use CTEQ6l1.
I personally agree that it might be better to stop the generation in this case.
I will discuss this with the other member of the team, before changing this point.

In order to check that your parameter are correctly taken into account, you need to look at one of the log file.
(on the results page (the one with the link to the output files)
-click on the cross-section
then you will see a page detailling the cross-section for each set of external particles
- click on one of the cross-section associate to one of those set (don't care which one)
Then you will see a table with
G1/G2/...
-click again on one of the associated cross-section (don't care which one)
and you will see one of the log.

If the pdf is not recoginzed this is explicitely written, close to the begining of this files.

Cheers,

Olivier

Busato (ebusato) said : #2

Hello,

Thanks Olivier. Looking at the log file I now see that lhapdf is never found, even when I put parameters I would expect to work:

    'lhapdf' = pdlabel ! PDF set
    21000 = lhaid ! PDF number used ONLY for LHAPDF

The log file says :
 ...
 Unimplemented distribution= lhapdf
 Implemented are: mrs02nl,mrs02nn,mrs0119,mrs0117,mrs0121,mrs01_j,...
 Setting it to default cteq6l1
 ...

I think I followed all the steps described in README.lhapdf (download/compile/install lhapdf 5.8.7, copy libLHAPDF.a in lib/, create lib/PDFsets/MSTW2008lo68cl.LHgrid, run bin/cleanall) and I don't see what I am missing.
I copied my installation on lxplus410:/tmp/ebusato/MadGraph5_v1_4_2 (my working directory is MyRunDir_4topVectSing_UFO/).
Is there anything wrong with my installation ? Are there some basic checks that I could perform to check it ?

cheers,
Emmanuel

Best Johan Alwall (johan-alwall) said : #3

Hello Emmanuel,

Indeed it seems like the LHAPDF functionality is broken in v. 1.4.x. Many thanks for pointing this out, we will fix it for version 1.4.4. In the meantime, perhaps you can use v. 1.3.33: https://launchpad.net/madgraph5/trunk/1.3.0/+download/MadGraph5_v1.3.33.tar.gz

All the best,
Johan

Busato (ebusato) said : #4

I moved to v1.3.3 and it works now.
Thanks a lot,
Emmanuel