Trying to test hard-core phase space point with MG5

Asked by neorobin on 2012-02-16

Dear Developer,

Trying to check my matrix elements' result I want to use madgrah to
calculate some testing phase space point and compare the two results.

I remember there was an standalone version that after changing the
model and process in proc_card.dat form the templete we could go to
the bin/./newprocess and generate Feynman diagrams and matrix.f in
a process folder like P1_gg_gg under Subprocess /. In MadGraph5_v1.3.33
I still could have above work done but when I go to the process folder like
P1_gg_gg and try "make" the program report error. I used to type make
and ./check then the matrix elements' results with the momentum
(phase space) choice would appear in the terminal. Now this standalone
version with check function seem to be disabled.

Any way to still let the check_as.f generate an executable ./check?
Thanks very!
neorobin

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier Mattelaer
Solved:
2012-02-16
Last query:
2012-02-16
Last reply:
2012-02-16

Hi,

In MG5, the way to produce standalone output is different than in MG4.
So this is the way to do:
./bin/mg5
mg5> import model sm
mg5> generate g g > g g
mg5> output standalone [NAME]

this will create the directory NAME, with the standalone version.
the rest is exactly like in MG4.
If this is the first time that you launch ./bin/mg5, I might be good to take a couple of minuts to follow the tutorial:
./bin/mg5
mg5> tutorial
(read and follow instructions)

Cheers,

Olivier

neorobin (xuan-chen) said : #2

Thanks Olivier Mattelaer, that solved my question.