getting errors when generating events from a user model

Asked by Oriol Domenech on 2012-02-15

Dear MGME developers,

first of all let me congratulate you for the great job you are doing with MGME 5, it's really amazing!

Now I come to my troubles with the new version. I'm a user of MGME 4 and I was trying to generate events for a certain process (p p > t t~) using a model of my own, so I was following the very same steps as in version 4, i.e. I create my own model and I import it using the import model_v4 usermodel command in the proc_card and then generate a new process, but, when trying to generate the events I get the following error message:

Compiling Source
Undefined symbols:
  "_setpara_", referenced from:
      _setrun_ in setrun.o
      _setrun_ in setrun.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [../bin/combine_events] Error 1
Error make ../bin/combine_events in Source not successful

I have no guess of what it means so I would really appreciate if you can give me a clue of what is going on.

Thank you very much in advance,

Oriol Domènech

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
Olivier Mattelaer Edit question
Solved by:
Oriol Domenech
Solved:
2012-02-16
Last query:
2012-02-16
Last reply:
2012-02-15

Hi,

you open two times the same question.
So I close this one, to have only one open topic.
I reply to the other one
https://answers.launchpad.net/madgraph5/+question/171694
directly

Hi,

ok looks like the other question was something else, that you edit by mistake.
So let do it here... (sorry for the confusion).

Like this, it looks like that one function is not correctly set.
could you send to me your model by email?
(<email address hidden>)

and then I will take a look.

As a first (non really satisfactory) solution
is to compile with g77 instead of gfortran

In order to compile with g77 by default
you need to edit the configuration file:
 ./input/mg5_configuration.txt

For the existing output, you can launch ./bin/change_compiler.py

I'll try to modify to understand what the problem is with gfortran. If so I'll post a comment here and push this in the next version of MG5.

Oriol Domenech (odomenech) said : #4

Dear Olivier,

thanks a lot for your comment. I changed the compiler to g77 instead of gfortran and now it works perfectly well.

Thanks a lot!

Oriol Domènech

H Zhang (witten-e) said : #5

Dear Olivier,

Do you solve this problem for gfortran? The problem is still there in v1.5.5.

Thank you.

Hao Zhang

Hi,

I just create a new usermod model on my computer, and it compiles correctly on my computer.
If you use an "old" template then it might be that this one is not gfortran compatible.

If you want, you can send me your model by email <email address hidden> and I can try to have a look at the problem.

Cheers,

Olivier

On Dec 15, 2012, at 7:31 PM, H Zhang <email address hidden> wrote:

> Question #187845 on MadGraph5 changed:
> https://answers.launchpad.net/madgraph5/+question/187845
>
> H Zhang posted a new comment:
> Dear Olivier,
>
> Do you solve this problem for gfortran? The problem is still there in
> v1.5.5.
>
> Thank you.
>
> Hao Zhang
>
> --
> You received this question notification because you are the assignee for
> this question.