Plots in MadAnalysis /Pythia jet matching

Asked by JenniferK on 2011-11-05

Hi,

as I'm trying now for quite a long time to solve the problem and don't get to the solution, I thought I could maybe ask here for help:

I'm generating processes like p p > ul go (+1jet) in the mssm.
Sometimes there is a problem with the parameters and I don't get a pythia-file as output.
(It changes to default values and then I get an error message "Creating matching plots.. root executable not found". But that's maybe not the main problem. If the pythia-events-files are created, they seem to look fine, as I get for example many additional gluons, so the PS etc. seem to work.
But when I'm plotting distributions like p_T or rapidity, they look very strange, as it's more like a "bar plot", than a continuous function. I thought it could be due to statistics, but changing the number of events does not change much.

I don't know, if you can help me with this little information. I could attach some cards or try something, but so far for now.

Thanks,
Jennifer

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Solved by:
JenniferK
Solved:
2011-11-07
Last query:
2011-11-07
Last reply:
2011-11-06

Hi Jennifer,

>I'm generating processes like p p > ul go (+1jet) in the mssm.
>Sometimes there is a problem with the parameters and I don't get a pythia-file as output.
>(It changes to default values and then I get an error message "Creating matching plots.. root executable not found". But that's >maybe not the main problem. If the pythia-events-files are created, they seem to look fine, as I get for example many additional >gluons, so the PS etc. seem to work.

The message "Creating matching plots.. root executable not found" informed you that the quite crucial matched plot cann't be created since those plots require that root is install on your computer and the environment variable ROOTSYS correctly configured. Otherwise up to the next version for using mssm with pythia, you are force to use the model mssm_v4 (via the command import model_v4 mssm_v4).
(Due to a SLAH1/2 convention mismatch). The next major version of MG (Which will arrive in Beta soon) include a converter between those two conventions and therefore fix the problem. So maybe this is your problem with pythia.

>But when I'm plotting distributions like p_T or rapidity, they look very strange, as it's more like a "bar plot", than a continuous >function. I thought it could be due to statistics, but changing the number of events does not change much.

Madgraph doesn't compute analytical curve for the p_T/rapidity/... so the results is not continuous. If you want to have smoother curve, you need to play with the parameter of MadAnalysis, but Since this part is in fortran, you cann't have more than 100 bin.

JenniferK (jenniferk) said : #2

Hi Olivier,

thanks for your help!
At the same time, I was installing root and tried again, so now it does not complain any more about creating matching plots.
And it also solved my problem with the distributions. I didn't expect really analytical curves, sorry for the misunderstanding, but the plots looked really strange, as there was even not a curve. But now it looks much better! So I think it came from the missing root.

I'll try also the model mssm_v4 for the "parameter"-problem then.

Thanks for help,
Jennifer

JenniferK (jenniferk) said : #3

Again:

I installed and configured root as it is described on the webpage of CERN (without any additional features) and I think, also the variable ROOTSYS is correctly configured.
I don't get the error message like before (Root executable not found), the plots are as they are supposed to be. But when I restart my computer, there is the same error message as before.
I don't know, if it's the right place to ask, but do I need maybe any additional features, and why does it work before restarting and after that not, without changing anything?

Cheers,
Jennifer

Try the following command in a new shell:
echo $ROOTSYS

if nothing appear this means that you have define ROOTSYS only in one shell.
In order to define it in all (new) shell you need to add in ~/.bashrc the following command:
export ROOTSYS=YOURPATH
so exactly the command that you use before but this time not executing it in the shell but writting it in that file.
(this file is normally executed when you open a shell)

Note that on mac, the file to edit is different: ~/.bash_profile

Cheers,

Olivier

PS: For more info, on how install root, you can follow the instructions on this page:
https://server06.fynu.ucl.ac.be/projects/madgraph/wiki/SchoolKias

JenniferK (jenniferk) said : #5

Thank you so much, Olivier.
Now everything seems to look fine.