MenuLibre doesn't run uder XFCE on Debian Jessie

Asked by jenningsthecat on 2014-01-26

Hello:

I finally managed to resolve various dependencies and got MenuLibre 2.0 installed from the tarball, but when I ran it from a terminal emulator this was the result:

** (menulibre:8966): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
ERROR:root:Could not find any typelib for GMenu
Traceback (most recent call last):
  File "/usr/local/bin/menulibre", line 31, in <module>
    import menulibre
  File "/usr/local/lib/python3.3/dist-packages/menulibre/__init__.py", line 23, in <module>
    from menulibre import MenulibreApplication
  File "/usr/local/lib/python3.3/dist-packages/menulibre/MenulibreApplication.py", line 24, in <module>
    from . import MenuEditor, MenulibreXdg, XmlMenuElementTree, util
  File "/usr/local/lib/python3.3/dist-packages/menulibre/MenuEditor.py", line 28, in <module>
    from gi.repository import GdkPixbuf, Gio, GLib, GMenu, Gtk
ImportError: cannot import name GMenu

I tried installing the packages gir1.2-gtksource-3.0, libgtksourceview-3.0-0, libgtksourceview-3.0-common, python-gmenu, and even gnome-menus. The behaviour remained the same even after logging out and back in. I then checked dependencies for Alacarte and found that all but two of them had already been satisfied by the installation of MenuLibre and my attempts to get it working. So just on spec I installed those two packages, (gir1.2-gmenu-3.0 and libgnome-menu-3.0); this forced the removal of gir1.2-gtksource-3.0 and libgtksourceview-3.0-0). Now when I try to run MenuLibre I get the following:

WARNING:menulibre: getDefaultMenuPrefix() 'No menu prefix found, MenuLibre will not function properly.'
Traceback (most recent call last):
  File "/usr/local/lib/python3.3/dist-packages/menulibre/MenulibreApplication.py", line 2247, in do_activate
    self.win = MenulibreWindow(self)
  File "/usr/local/lib/python3.3/dist-packages/menulibre/MenulibreApplication.py", line 338, in __init__
    self.configure_application_treeview(builder)
  File "/usr/local/lib/python3.3/dist-packages/menulibre/MenulibreApplication.py", line 614, in configure_application_treeview
    selection.set_select_function(self.on_treeview_selection)
TypeError: set_select_function() takes exactly 3 arguments (2 given)
^C
^X
quit
exit

(The last four lines are my attempts to stop the script).

I now realize that my current problems are probably a dupe of Bug #1271914. I hope I can get a solution to this - I'd rather not use Alacarte.

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
MenuLibre Edit question
Assignee:
No assignee Edit question
Solved by:
Sean Davis
Solved:
2014-01-30
Last query:
2014-01-30
Last reply:
2014-01-27

Just installed Alacrte, (all the dependencies were already present anyway), and it runs properly, so whatever is preventing MenuLibre from running is not used by Alacarte.

Best Sean Davis (bluesabre) said : #2

I've released a new version of MenuLibre with this fix in place. It should be available in Debian soon.

Thanks Sean Davis, that solved my question.

Thanks very much for your responsiveness - the new version works. A couple of notes:

1) The Debian package available at http://packages.debian.org/unstable/main/menulibre claims to be version 2.0.2-1, and the files inside the package have date stamps of Jan 29 02:09. However, launching MenuLibre after installing this package resulted in the same behaviour I described in my original post. I had to uninstall the package, download the newest tarball from Launchpad, and run the Python setup file before MenuLibre would work.

2) On my system MenuLibre launches with a "Couldn't register with accessibility bus" warning. It doesn't seem to cause any problems, and I'm noting it on the off chance that you find the info helpful.

3) I notice that MenuLibre doesn't show XFCE root menu entries such as 'Mail Reader' and 'Web Browser'. Is MenuLibre capable of showing and editing these entries, or do I need to manually edit .desktop files and/or the xfce4-applications.menu file?

Thanks!