Installed Debian Sid XFCE - No Menu Prefix Found

Asked by David L. Craig on 2014-01-21

After the .deb file was installed, I clicked on the new Applications -> Accessories -> Menu Edit icon but nothing popped up. I read the man page, discovered the documentation wki is not yet established, and tried menulibre -v from a terminal emulation session:

DEBUG:menulibre: set_up_logging() 'logging enabled'
WARNING:menulibre: getDefaultMenuPrefix() 'No menu prefix found, MenuLibre will not function properly.'
DEBUG:menulibre: __init__() 'Using menu: /home/dlc/.config/menus/applications.menu'
DEBUG:menulibre: block() 'Blocking history updates'
DEBUG:menulibre: unblock() 'Unblocking history updates'
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/menulibre/MenulibreApplication.py", line 2247, in do_activate
    self.win = MenulibreWindow(self)
  File "/usr/lib/python3/dist-packages/menulibre/MenulibreApplication.py", line 338, in __init__
    self.configure_application_treeview(builder)
  File "/usr/lib/python3/dist-packages/menulibre/MenulibreApplication.py", line 614, in configure_application_treeview
    selection.set_select_function(self.on_treeview_selection)
TypeError: set_select_function() takes exactly 3 arguments (2 given)

and execution has to put in background then sent a SIGHUP to terminate.

Should I open a Debian bug or can someone point me to a manual?

Question information

Language:
English Edit question
Status:
Solved
For:
MenuLibre Edit question
Assignee:
No assignee Edit question
Solved by:
David L. Craig
Solved:
2014-03-09
Last query:
2014-03-09
Last reply:
Sean Davis (bluesabre) said : #1

We haven't finished the online documentation yet, but it seems like there are two problems here.

1. It seems stock Xfce does not set the prefix variable.
2. The API in that version of python-gi seems to be more strict.

I'll have a look at both issues, and create a bug from this question. Thanks!

David L. Craig (dlc) said : #2

I recently upgraded to version 2.0.2-1 and the problem is resolved. Thank you.