I can't figure out how to build/install MenuLibre

Asked by jenningsthecat

I am using XFCE under Debian Wheezy.

I have downloaded and unpacked the file 'menulibre_13.03.16.tar.gz' from the Download link on 'https://launchpad.net/menulibre'. At first I assumed that making 'setup.py' executable, and executing in a terminal, would install MenuLibre; but when I try that I get a 'command not found' error, even though I'm currently in the directory where the file resides.

There is no makefile among the extracted files, so I can't do the usual "make / make install" routine. How do I go about installing this program?

I generally rely on Debian packages for software that's not in the repos, so I don't have a lot of experience installing from tarballs. Any help would be greatly appreciated.


Question information

English Edit question
MenuLibre Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
jenningsthecat (jenningsthecat) said :

Just solved the initial problem - I needed a './' , (dot-slash) in front of the 'setup.py' command.

However, when I execute setup, I get the following:

usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: setup.py --help [cmd1 cmd2 ...]
   or: setup.py --help-commands
   or: setup.py cmd --help

error: no commands supplied

I've been unable to find any documentation or reference that tells me what arguments to supply. Help?

Thanks again!

Revision history for this message
Sean Davis (bluesabre) said :


sudo python setup.py install


Revision history for this message
jenningsthecat (jenningsthecat) said :

Awesome - thanks so much!

Revision history for this message
cwynd (cclarke) said :

Hello All, trying to use MenuLibre just like the OP on a clean Wheezy / XFCE install, without installing all of gnome deps as well. Following the above instructions, MenuLibre appears to get installed ok, however it will not start. Running from a terminal I find this:
$ menulibre
ERROR:root:Could not find any typelib for GtkSource
Traceback (most recent call last):
  File "/usr/local/bin/menulibre", line 48, in <module>
    import menulibre
  File "/usr/local/lib/python2.7/dist-packages/menulibre/__init__.py", line 25, in <module>
    from menulibre import MenulibreWindow
  File "/usr/local/lib/python2.7/dist-packages/menulibre/MenulibreWindow.py", line 23, in <module>
    from gi.repository import Gtk, Gdk, GdkPixbuf, GObject, GtkSource # pylint: disable=E0611
ImportError: cannot import name GtkSource

Searching (for me anyway) offers little-to-no guidance on how to fix this.

I imagine I might solve it by installing gnome, but the "weight" of that is daunting - example for installing alacarte menu editor:
$ sudo apt-get install alacarte -s
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
0 upgraded, 161 newly installed, 0 to remove and 9 not upgraded.

Massive! I am hoping maybe to get some advice on a way to satisfy above dep without doing a complete gnome install...

Thanks in advance for any help.

Revision history for this message
Sean Davis (bluesabre) said :

Try installing these packages:


Revision history for this message
cwynd (cclarke) said :

Thanks so much, that did the trick :)