Feisty package of Amarok correctly reading m4a tags?

Asked by JW on 2007-04-12

I'm currently using Edgy and the standard Amarok I can get does not always read m4a tags correctly. I can change the tags using EasyTag (a patched version) just fine.

I see there is no longer an amarok-engines package or amarok-xine package for Edgy. I'm planning a Feisty upgrade soon anyway, and I'm just curious whether the medibuntu amarok packages will allow the m4a tags to be read correctly. (Written would be cool too, but I'm mostly interested in reading them correctly.)

Question information

Language:
English Edit question
Status:
Solved
For:
Medibuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-04-17
Last reply:
2007-04-16

This question was reopened

  • 2007-04-14 by JW
JW (arch0njw) said : #1

"I see there is no longer an amarok-engines package or amarok-xine package for Edgy." <-- by that I meant on the medibuntu site.

Marco Rodrigues (gothicx) said : #2

I suggest you to upgrade to feisty =)

JW (arch0njw) said : #3

Funny fellow... ;-)

So, yeah, that fixed it. Of course, I'm now having other problems (like graphics card issues). One piece at a time!

JW (arch0njw) said : #4

Alas, I spoke too soon. I'm still having the same problem, I just did not look at my "Unknown" genre when I last spoke. I actually noticed this by trying to retag one of my "Rock/Pop" albums to "Alternative Rock" -- and it did not move (even after a library rebuild).

m4a tags are not read correctly, particularly genre. :-(

Albin Tonnerre (lutin) said : #5

I'd say it's an upstream issue, not a medibuntu one. Amarok in medibuntu is linked against mp4 libs, but we can't really do something if that mp4 does not work as expected, as it's not a packaging issue. Maybe this would rather concern amarok's developers.
Cheers

JW (arch0njw) said : #6

Albin -- thanks. I'll try there. Cheers!

Albin Tonnerre (lutin) said : #7

Ok, marking this request as solved then

JW (arch0njw) said : #8

I just like to have a final answer to something. I copied the m4a files to a windows machine (*shudder*) and copied them into iTunes. iTunes didn't even read the tags correctly. I retagged them and then coped them back. I can even EDIT the tags in Amarok now.

I can only guess at the problem; perhaps something screwy in the tagging that prevented anything else from reading them correctly.