Lost libavcodec* packages in intrepid

Asked by Sergey V. Udaltsov on 2008-10-14

On http://packages.medibuntu.org/intrepid/ there are no libavcodec1d (neither libavcodec-dev). Just to compare, that package is available for hardy.

Question information

Language:
English Edit question
Status:
Solved
For:
Medibuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Lionel Le Folgoc
Solved:
Last query:
Last reply:

Actually, same story about ffmpeg

Lionel Le Folgoc (mrpouit) said : #2

Hi,

That's because they shouldn't be needed anymore, as Ubuntu ships an unstripped variant of ffmpeg in intrepid/multiverse (http://packages.ubuntu.com/source/intrepid/ffmpeg) that should contain all codecs needed.

Philip Macpherson (philipmac1) said : #3

I installed all the unstripped versions. However winff won't convert most things still and ffmpeg only reports this:

configuration: --enable-gpl --enable-pp --enable-swscaler --enable-x11grab --prefix=/usr --enable-libgsm --enable-libtheora --enable-libvorbis --enable-pthreads --disable-strip --enable-libfaad --enable-libfaadbin --enable-liba52 --enable-liba52bin --enable-libdc1394 --disable-armv5te --disable-armv6 --disable-altivec --disable-vis --enable-shared --disable-static

Have I installed the right thing or is unstripped still really limited?

Lionel Le Folgoc (mrpouit) said : #4

Yes, you installed the right thing (the latest upload of *unstripped* adds missing aac and xvid support).

The ffmpeg binary will output the configuration from the standard (intrepid/main) variant (where many codecs are stripped), but if the unstripped (intrepid/multiverse) variants are installed, it'll use them (although the configuration output doesn't change).

Lionel Le Folgoc (mrpouit) said : #5

To reply to someone on IRC:
[02:06] <crazy_bus> mr_pouit: thanks for the answer. Do I have to restart to stop receiving Unknown encoded xvid

Iirc, the encoder to pass is libxvid (but I don't have ffmpeg right now to check).

Philip Macpherson (philipmac1) said : #6

Yes that was me. I fixed that problem by downloading a new preset file for winff which wasn't using commands like libxvid and libmp3lame

Apparently, ubuntu's ffmpeg does not contain all necessary codecs. I am using transcode (from dvdrip frontend), getting the error:

[export_ffmpeg.so] Could not find a FFMPEG codec for 'mpeg4'.
[transcode] warning : (encoder.c) video export module error: init failed

FWIW, the versions are:
libavcodec51 3.0.svn20080206-12ubuntu3 (for PowerPC)

Best Lionel Le Folgoc (mrpouit) said : #9

As written above, you need to install the unstripped variant (i.e. libavcodec-unstripped-51) to get all necessary codecs.

Thanks Lionel Le Folgoc, that solved my question.

The only thing which probably should be explained - how people would know about that essential detail... Is it documented anywhere?

Lionel Le Folgoc (mrpouit) said : #12

It is documented here: https://help.ubuntu.com/community/RestrictedFormats
If people read this page and install ubuntu-restricted-extras/kubuntu-restricted-extras/xubuntu-restricted-extras, everything should be fine, as it depends on libavcodec-unstripped-51.