no video - can record and playback on Totem

Asked by Gordon on 2009-08-14

Get no video or sound with Me-tv 0.9.4 on Fedora 11 x86_64 with an nvidia GeForce 7300GT.
Much to my surprise I found I could record a channel and play it back with sound with Totem.
The Tv card is
saa7133[0]: subsystem: 17de:7253, board: KWorld DVB-T 210 [card=114,insmod option]

I assume I should see the program playing in the black area above the program list.

Question information

English Edit question
Me TV Edit question
No assignee Edit question
Last query:
Last reply:

This question was reopened

I think that you need to install the version of xine-lib/xine from RPMFusion. Try Me TV 1.0.0.

Gordon (gdr01) said : #2

I just want to watch it on the same PC, so am I supposed to run me-tv to capture and xine to watch it?
Is there a How-to anywhere or more documentation that explains the preferences?

Scott Evans (vk7hse) said : #3


Your missing is an equivalent to 'libxine1-ffmpeg' as previous versions on Me TV (packaged for ubuntu) relied on 'xine-ui' this uses 'libxine1-ffmpeg' (as a dependency) Me TV now uses a custom me-tv-xine to render and as a result of this to resolve the black screen (no video) you will need to satisfy this library...

I'm assuming (I shouldn't) that you are building from source? if so you may wish to ask the package maintainer that is building the .rpm's to update to the latest for you ... then the dependency issue will be sorted for you...

Hope that this helps you a little! ;)


Scott and Gordon,

The xine-lib that comes with Fedora is deliberately MPEG crippled to avoid any patent violations. There is another repository called RPMFusion that Fedora guys use to play MPEG content. Here is a one of many websites that discuss this issue, It also explains how to fix this.

In short, Scott's recommendation to upgrade will not work, you will still have the same problem.

Gordon, I'm surprised that you haven't heard of it, it's the only way to play patent encumbered content under Fedora. Sorry, it was my assumption that you would know what I was talking about when I mentioned RPMFusion.



Scott Evans (vk7hse) said : #5

Thanks for clarifying this Michael, as you I'm not a Fedora user! so I was
unaware of this! I really should broaden my general knowledge! ;)

Scott Evans VK7HSE
Phone: +61362291658
Mobile: +61417586157
Skype: vk7hse
<email address hidden>
PGP/GPG Key ID 437E00F9

This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Gordon (gdr01) said : #6

I never associated music/mpeg issues with a TV display. As I seldom listen to music.

So you both gave me a different line of attack to follow up - thank you. I have had this TV card for 6 months and only got it to work under XP to test the aerial and card. The new kernel in F11 finally started to recognise the tuner on the TV card and then me-tv started to half work once I got a working channels.conf. (I am in Scotland)

As the above how to link is for F10 and I do have yum pointing at the RPMFusion repository I found and installed
xine-lib-extras-freeworld.x86_64 as I already had the gstreamer-ffmpeg.x86_64 installed.

So now when I load me-tv I get --------- 'Timeout while reading'
then -------- ' There is no stream to record'

I start me-tv from the command line and get the following
(me-tv:3335): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(me-tv:3335): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(me-tv:3335): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(me-tv:3335): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(me-tv:3335): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(me-tv:3335): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(me-tv:3335): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

(me-tv:3335): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed
15/08/09 14:32:08: Setting display channel to 'BBC NEWS 24' (6)
15/08/09 14:32:08: Waiting for signal lock ...
15/08/09 14:32:09: Got signal lock
the error message window is permanent and does not disappear when I clock OK

The error is indicating that you have a DVB setup issue. Have you got your DVB setup working using any other Linux applications?

Gordon (gdr01) said : #8

No up until now nothing.
However I have just reinstalled kmod-nvidia* and xorg-x11-drv-nvidia* ... and
it is now working - I got video and sound ... ;-))

I still get those GTK-warnings and critical messages but it still works.
Changing channels is slow but as I have been unable to use the program properley I am unsure what to expect.

Gordon (gdr01) said : #9

I am happy if you want to close it.

If you require further data for your research let me know.

The reason I reloaded the nvidia drivers is I tried to run worldofpadman and it failed with a - no openglx error.
I tried running glxgears and it failed.

The latest version should solve most of the other issues. The original question has been solved.

Gordon (gdr01) said : #11

Trying to compile me-tv 1
I have managed to get all the required devel libs from my Fedora resources but cannot get libxine
configure fails with
 Package requirements (libxine >= 1.1.7) were not met

My system has

libXinerama.x86_64 1.0.3-4.fc11 installed

where do I get libxine 1.1.7 ?

Luboš Staněk (lubek) said : #12

You need to install the package that provides the libxine's pkgconfig script:
yum whatprovides /usr/lib64/pkgconfig/libxine.pc

It is worth to learn about building RPMs in your distribution if you want to build your own binaries.
You will quickly clash with the SELinux, FHS, and distribution rules.

Original question solved.