Will not scan in Ubuntu 9.04

Asked by ayellen on 2009-05-04

I recently (only hours ago) upgraded to Ubuntu 9.04 (from 8.10.) In the upgrade, all of a sudden, me-tv will not work!

I use the Win-TV HVR-950.
Ubuntu recognizes the card -- as shown by the fact that my analogue works fine with tvtime. However, when I open up me-tv, it recognizes my device as: LG Electronics LGDT3303 VSB/QAM Frontend, and when I press to scan, it says:
"Failed to scan: scanning is only supported for DVB-T and DVB-C devices."

I'm quite confused, as this worked fine in 8.10! (I'm also confused by its recognition of my device as something else, though I'm willing to assume that is the internals of the HVR-950 and I'd never know the difference, anyway...)

Any ideas?
Thanks!
ay

Question information

Language:
English Edit question
Status:
Solved
For:
Me TV Edit question
Assignee:
No assignee Edit question
Solved by:
ayellen
Solved:
2009-05-04
Last query:
2009-05-04
Last reply:
2009-05-04
Scott Evans (vk7hse) said : #1

Firstly I have to say that I'm not familiar with your receiving card as
I use a USB DVB-T device! However, I'm wondering if by chance you
have/had compiled from the linuxtv site their DVB-utils/DVB-apps or if
you have just let the dependencies for Me TV be sorted by the
installable .deb file?

As your DVB device is internal card what do you get when you issue
lspci ?

For instance as mine is a USB device I get the following from lsusb...
Bus 001 Device 006: ID 2304:0236 Pinnacle Systems, Inc. [hex] this is
identified in Me TV as DIBcom 7000PC! but all works just fine.

Anyway back to your issue can you check in the view/devices menu in Me
TV to check that you don't have more than one listing, and if is has try
using the other device (should there be another one listed)

Scott Evans VK7HSE
Phone: +61362291658
Mobile: +61417586157
Skype: vk7hse
<email address hidden>
http://www.vk7hse.hobby-site.org
PGP/GPG Key ID 74639624

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

ayellen (ayellen) said : #2

I'm 95% sure I compiled stuff from the linuxtv site. (Though, truthfully, in my attempt to figure out what was going on, I did 5 or 6 different things and cannot tell you exactly what anymore...)

My card is not an internal device at all; it is a USB device. (It is this: http://www.hauppauge.com/site/products/data_hvr950.html) My lsusb gives me (among other things:)
Bus 001 Device 005: ID 2040:6513 Hauppauge

Me-tv does not list any other devices; only the LG mentioned above.

Scott Evans (vk7hse) said : #3

My apologies! when I hear of that brand I always think of internal
devices!

On Mon, 2009-05-04 at 08:26 +0000, ayellen wrote:
> Question #69847 on Me TV changed:
> https://answers.launchpad.net/me-tv/+question/69847
>
> Status: Answered => Open
>
> ayellen is still having a problem:
> I'm 95% sure I compiled stuff from the linuxtv site. (Though,
> truthfully, in my attempt to figure out what was going on, I did 5 or 6
> different things and cannot tell you exactly what anymore...)
>
> My card is not an internal device at all; it is a USB device. (It is this: http://www.hauppauge.com/site/products/data_hvr950.html) My lsusb gives me (among other things:)
> Bus 001 Device 005: ID 2040:6513 Hauppauge
>
> Me-tv does not list any other devices; only the LG mentioned above.
>

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Me TV has not been able to scan ATSC since 0.5.X but you can import a pre-generated channels.conf from the scan application.

As time goes by you should expect features to be added and removed based on the people contributing to the project.

ayellen (ayellen) said : #5

Well, that certainly explains it!

Downgrade, here I come! (Or switch to Kaffeine...ew!)

Or generate a channels.conf with "scan" command line application. Me TV supports ATSC, it just can't scan ATSC. You need to use an external utility like scan.

Bruce Freeman (brucefreeman) said : #7

I am having the same issue with 9.10.

I only see one device in Me-TV under devices and it is my device.

Other scan applications don't seem able to create an initial scan file either. Result with error messages:

w_scan error:
ERROR: Sorry - i couldn't get any working frequency/transponder
 Nothing to scan!!

dvbscan errors:
bruce@bruce-desktop:~$ dvbscan /usr/share/dvb/atsc/us-NTSC-center-frequencies-8VSB
Unable to query frontend status
bruce@bruce-desktop:~$ dvbscan /usr/share/dvb/atsc/us-ATSC-center-frequencies-8VSB
Unable to query frontend status
bruce@bruce-desktop:~$ dvbscan /usr/share/dvb/atsc/us-ATSC-center-frequencies-8VSB
Unable to query frontend status

Attempts with scan errors:
bruce@bruce-desktop:~$ scan -c -v -a 0
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
WARNING: filter timeout pid 0x0000
WARNING: filter timeout pid 0x1ffb
dumping lists (0 services)
Done.
bruce@bruce-desktop:~$ scan -c -v -a0 -t1 -A2
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
WARNING: filter timeout pid 0x0000
WARNING: filter timeout pid 0x1ffb
dumping lists (0 services)
Done.

Here is the output of my lspci

bruce@bruce-desktop:~$ lspci
00:00.0 Host bridge: ATI Technologies Inc Radeon Xpress 200 Host Bridge (rev 01)
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:11.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:12.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 82)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9500 GT] (rev a1)
02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
02:04.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)
02:04.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)

Suggestions???? I am new to Linux if that's not already obvious.

"I am having the same issue with 9.10." .. what issue, that it wont scan? Me TV 1.0.0 will not scan ATSC.

Only one application can open the DVB device at a time. Maybe you still have Me TV running when you are running dvbscan. Check the notification area to see if it's running in the background.