Hauppauge HVR 3000 and Me-TV

Asked by Robin Kluth on 2009-03-09

Hey Me-TV Team!

I have an Hauppauge HVR 3000 TV-Card and this problem:

My OS is Ubuntu 8.10 and with this OS the latest me-tv version for 8.10.

My TV-card was detected from linux successfully, but after i start me-tv it shows me it want to scan channels - ok.

But after it starts, it says "Cannot change Transponder xxx" (in german: Umschalten zu Transponder xxx fehlgeschlagen) after this error it leaves me alone...
I've heared DVB-S is supported? but - not in my version, isnt it? My exactly me-tv version:

$ apt-show-versions me-tv
me-tv/intrepid uptodate 0.5.30-1

What can I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Me TV Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Lamothe
Solved:
2009-03-13
Last query:
2009-03-13
Last reply:
2009-03-13
Scott Evans (vk7hse) said : #1

Hi...

The current stable version of Me Tv is 0.7.16 This is available via the
Me Tv Development PPA.

To get this latest version you will need to add to
your /etc/apt/sources.list the following...

deb http://ppa.launchpad.net/me-tv-development/ppa/ubuntu intrepid main

deb-src http://ppa.launchpad.net/me-tv-development/ppa/ubuntu intrepid main

and also you will need to ad the PGP key into synaptic as well..

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: SKS 1.0.10

mI0ESY5Z0QEEAKR5RraAASH6IlGmq969yXXCwf3r00FYAup9Gh8hqL50IZbrAjN+TyxAlJsx
jc/d3bTq+MMChpvDpH8EucoAPT0QuC9Bo8Q0koxh71yeh++lfs1ZNzqfT2q5pyDAUIvBy5wR
Lw8OkwqB8jWhHuF6aJqNH1n8TKM1Jhlgdl11igsFABEBAAG0I0xhdW5jaHBhZCBQUEEgZm9y
IE1lIFRWIERldmVsb3BtZW50iLYEEwECACAFAkmOWdECGwMGCwkIBwMCBBUCCAMEFgIDAQIe
AQIXgAAKCRA5EhNN19wRRpS6A/9VfjqX22bSRSOTOkVejQipmr1Gssr/ejlkp74ShIjZktYd
aJBUn3ZGbI2n3MgjgQBlu6bZYszEyH6yE5/Dr8P3hJhKUfaJvhJJz59qpj4XyAGlXd0L5RRP
QiFsNjajKNCpsKuudahKiXSl6UqedUK7/1PR6pZnnaIHNGmbW5QE4Q==
=X9DI
-----END PGP PUBLIC KEY BLOCK-----

If you're unsure of how to do that then take a look at the following
link for further advice...

https://help.launchpad.net/Packaging/PPA#Adding%20a%20PPA%20to%20your%
20Ubuntu%20repositories

Scott Evans VK7HSE
Phone: +61362291658
Mobile: +61417586157
Skype: vk7hse
<email address hidden>
http://www.vk7hse.hobby-site.org
PGP/GPG Key ID 74639624

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

I think that Robin is specifically asking for DVB-S support. Me TV 0.7.16 will not help you with that, neither 0.6 or 0.7 have DVB-S support.

The version that you are using does support DVB-S but the scanner does not work well for DVB-S. What you need to do is generate a channels.conf and put it at ~/.me-tv/channels.conf.

Thanks,

Michael

Robin Kluth (commifreak) said : #3

Yes! I asked for DVB-S Support, because my HVR has direct Coaxial-input, and i want to use it :D.

@Michael: 0.6/0.7 doesnt support DVB-S?? Why does support the version 0.5.30 it? Version 0.6 and above are newer - arent they?

About the channels.conf: How can i generate this file? Which program can i use for my card to do this?

Thanks for the answers ;)

Greetz,
R. Kluth

Robin Kluth (commifreak) said : #4

[No edit available? -.-]

Do i need some F/W for my card? Or drivers to work with me-tv?

Back to the versions: I've read the dvb-s support was dropped from 0.6 and above because of some problems - ok i understood why you give me 0.5.x :D

You need a supported and working DVB device under Linux.

Robin Kluth (commifreak) said : #7

I know - but i dont know if i have to install some drivers for my card.

I dont see any DVB-S support in scan, only a param:

-satpos <position> Specify DISEQC switch position for DVB-S.

but this is for DISEQC. Does scan support DVB-S scans?

----

I've read that you're searching people to test the new DVB-S support (on the startpage) If you want, you can contact me for testing this.

> I know - but i dont know if i have to install some drivers for my card.

Neither do I, look at linuxtv.org, #linuxtv or their mailing list

For information on DVB-S scanning see https://answers.edge.launchpad.net/me-tv/+faq/122

Robin Kluth (commifreak) said : #9

I've read the manual - I have found this:

scan -o vdr -e 6 Astra-19.2E

but this command exit with some errors:

robin@home:/usr/share/dvb/dvb-s$ scan -o vdr -e 6 Astra-19.2E > /home/robin/chan.conf
scanning Astra-19.2E
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 12551500 V 22000000 5
WARNING: frontend type (OFDM) is not compatible with requested tuning type (QPSK)
ERROR: initial tuning failed
dumping lists (0 services)
Done.

Any Ideas?

Robin Kluth (commifreak) said : #10

Does anybody has an correct generated channels.conf? Astra 19.2E ?

If I'm not mistaken, your device has both a DVB-S and a DVB-T tuner on it. The scan command is obviously picking up the DVB-T tuner by default, you just need to specify which frontend device to use.

Robin Kluth (commifreak) said : #12

robin@home:/dev/dvb/adapter0$ dir
demux0 dvr0 frontend0 net0

There is no other frontend

So you don't have a /dev/dvb/adapter1?

Robin Kluth (commifreak) said : #14

>> If I'm not mistaken, your device has both a DVB-S and a DVB-T tuner on it

Yes, you're right. My Card has DVB-S support

>> So you don't have a /dev/dvb/adapter1?

See:
robin@home:/dev/dvb$ dir
adapter0

nope - no other adapter - This is the prob because i asked for some drivers.. is the dvb-s support not supported by default drivers? I dont know it

You're asking in the wrong spot. Me TV is a user-space application, you are asking for a device driver. See my earlier message about who you should contact. #linuxtv on FreeNode is a good start.

Robin Kluth (commifreak) said : #16

Sorry if you dont understood what i wanted to say: I know that me-tv is an program to view tv - and that doesnt is a driver :D

I will ask @ linuxtv - thanks for your help, and have good luck with the future versions of me-tv - and i hope for better dvb-s support in 0.8 ;)

Robin Kluth (commifreak) said : #17

Thanks Michael Lamothe, that solved my question.